Yoke going right! (happened again...) help me please :(

So… I was landing in SLC and everything seems fine, and when I was in 1000 ft the yoke turned right hardly there was no strong wind so I tried to recalibrate me device and it didn’t help… I wasn’t able to clean the screen cache because it was Boeing 739 and there is no APPR. And than my yoke pulled up hardly and I had to fight it. I don’t know why but I succeeded the touchdown and than my plane turned right and pulled up… So I crashed on the “terminal”.
Edit: happened to me again in Sydney… Can’t fly like this!!!

1 Like

Did u forget to turn off autopilot heading? Or possibly clicked heading on accident

Nope, nothing except trim

Sounds like there was some crosswinds on landing. It also sounds like you had some form of AP on cause the yoke won’t just move on it’s own unless there is an acting force on it. I know you said nothing was activated with AP, so I would say see if you can recreate it in solo.

No winds… The AP wasn’t active

Use the collaboration thing in the menu

I had something similar happen when I took off from JFK. No major winds and the plane just went right for no apparent reason everything was calibrated but I was actually able to save it by turning AP on but i couldn’t do anything to get the plane to go straight or left

What was your speed.If your speed was to low it could’ve been a stall

Based on what u gave us
I suspect a stall or yoke glitch

I’ve had a glitch where the yoke locks in place before
But haven’t had one in months so

No… Was normal speed

So I can’t prevent it?

Ok so let me get this straight before we try to run through some stuff.

You were on final passing through 1000ft when your aircraft suddenly (not violently) veered right with a nose pitch up included. You managed to execute the landing before it happened again when you were wheels down on taxi?

You have already tried:

  • calibrating the device
  • ensured AP was off
  • B739 so no APPR
  • you know for a fact you were above minimum speed.

No… In the final it happened (the right staff) and than I fought it and reached 400ft and than the planed pulled up and my speed wasn’t high so I almost stalled… And than in the touchdown the plane pulled up with the nose and turned right again like a weird takeoff but my speed was around 110kts and I stalled

This is odd.

Calibration can not always be 100% effective when you’re already in a vertical/horizontal motion. I’d say this is likely why. It would also explain the sudden pulling up by the yoke.

Here you say it’s normal, but then

Here you say it wasn’t. You need to provide accurate and consistent feedback for us to fix this for you.

  • Had you utilised trim?
1 Like

I am quite sure, given your speed, that it was a stall. That is really the only explanation that I can see being plausible. There are no known glitches with the yoke that I have found.

1 Like

I think you accidentally pressed the NAV buttun but, since only the NAV buttun lights up, I guess you didn’t notice it.

2 Likes

I didn’t…

The speed was 110kts after touchdown when the plane pulled up again

That’s why
U stalled 110knts is dangerously slow for B739

U likely had your nose pitch up and banked right towards the surface