Weird battery issue

Guys- I know that many people have battery issues with their devices. Mine I believe is unique. Yesterday, I did KLAX-KSEA-KSAN-KSFO-KBOS all in one day, and my battery life would fall when I had full brightness on, and then once I got into cruise it would work its way back to 100%. Today, I have only made one flight, and it has steadily been declining the entire day. What could have changed? I have tested my cords, outlet, and port.

1 Like

The full brightness is your issue, full brightness DRAINS your battery. And doing that many flights in a row is a lot. I would normally suggest giving your device 15 minutes turned off to cool down after a flight.

1 Like

My brightness is as low as it will go during cruise. Yesterday it handled the long flights easily.

I have a solution that actually increases your battery during long haul flights!


AT CRUISE:

  • Lower Brightness to Zero
  • Set Rendering Quality to Low
  • Set Rendering Resolution to Low
  • Set Anti-Aliasing to Off
  • Enable ‘Limit Frame Rate’
  • Lower Any Other Graphics Settings
  • Enable ‘Automatic Low Power’ (in-game settings)
  • Enable Low Power Mode (iPhone Only)
2 Likes

Also you should cover your device like with a clipboard or a blanket.

Actually, that could start a fire if you put a blanket over your device during long-haul flights. Personally, I would not suggest that. @CPT_Colorado


If you do many long-hauls in a row, your device’s battery lifespan will decrease… by a lot! The best solution if you’ve tried everything is to get a battery replacement.

Also make sure you use a high quality charging cable. Sometimes plugged into a UBS slot on a computer may not provide as much charging power than if you use the cord plugged into the wall. Sometimes you end up using more power than what the charging can provide.

1 Like

Thank you everyone

1 Like

Just to add to Noah here, the reason you really should not put any sort of cover/blanket on your device is that it actually restricts the airflow that your device has. This means that it is the ‘same’ air that is being constantly heated without a way for ‘new’ (cold) air to get into the device to cool it down. This effect then causes the device to heat up to the point where performance may be negatively effected (such as the operating system slowing down the processes the application uses to allow the device to cool down).

On the contrary, if you have any cases on your device you should remove them and put your iPad in a place which has constant airflow. I don’t know the data on how much doing this actually improves performance and device temperature, but it certainly does to a degree.

1 Like

Yes, exactly. I worry most about overheating and the device catching on fire when you’re away from it.

1 Like

You simply cover the screen, you don’t wrap it. It’s just for your brightness. Unless the screen “breathing”

I had some of the same issues. I got myself a lightning cable and a 20W charger. I usually don’t start a flight unless my battery is 100%. And then it maintains that 100% the entire flight. Also, luckily for me I live in MN where it’s late fall/winter now so when I start a flight I’ll sometimes leave my device plugged in, in the garage to keep it nice and cool!

I recommend putting your device next to a window or fun or on something cool to make sure nothing overheats.

Update: En route from JFK to HECA. It is now gaining battery. Not sure what happened.

This used to happen on my old phone. I would suggest you to check your battery health…

I think It matters from what kind of IPHONE you have 11-12 you have a lot of battery time 6 is less battery time and it goes on.

One more thing I’ve found helps is turn the volume all the way down.
Idk why but apparently the constant engine sound drains battery life like mad.
Once I get into cruise, I turn the volume all the way down.

If you want to further reduce battery consumption while you are away from your device (cruise for example), you can further lower the brightness in the following way:

Go to iPhone/iPad settings -> accessibility -> display and text size -> reduce white point (100%)

Nothing should happen with IF if you just go to the device settings for a short period of time.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.