Unicom at destination not on freq list until on 5nm final

Happened twice.
Today KMEM. Yesterday KRSW.
Latest IF downloaded, iPhone 7, latest iOS. Also using IFA.
KMEM using WiFi with no connection issues.
KRSW using 4G cellular.
All nearby airports appear, and can be tuned in. Started looking at about 25nm.


I’d just like to rule out one thing:
Did you happen to be at an abnormally high altitude during your approach?

There was an addition in the latest update that prevents users over a certain altitude from accessing unicom (not 100% sure on specifics).


Good thought, but no…at 25nm out was descending thru 11k

That’s all I have on this one. Someone who can better assist you will take over, luck. :)

1 Like

If your airport is close to sea level that’s a bit high, might have been the reason.

@GBIRD, did you by chance take a screen shot of it not showing as well as where you were on the map? Also, what did your route look like? the distance to destination is based on what your flight path takes you, while in my head i cant figure out why that would be smaller than 25nm physically out, maybe its possible?

No screen shot. And to clarify, at the outer ring into KMEM I was at 3500’ , in the cone, on the glide slope, still no KMEM in the list. It finally appeared 5-7nm from airport.

1 Like

Very odd. obviously shouldn’t be happening when flying. Maybe next time you notice it going on take a quick snapshot of your hud, distance to location and the map and see whats going on. I just tried to replicate it at MEM on Expert and didnt have an issue with it pulling up


same for me at KCLT from EHAM but it didn’t show up till after i landed


Also me too, last night i was KATL - TNCM using Delta A319. When i was on final runway 10 I did not find the frequency of the airport I was headed for.
Even though it is below 25 nm.

Maybe you can try to reopen the application or restart your device (?)


Could it havd been the API Servers was off maybe?

1 Like

Would that cause it??
I noticed more API disconnections ( only momentarily), since the last update. Note; when API was not connected, all other connections had green check mark.

This has happened to me twice as well (KBIL, KDLH)

1 Like

This happened to me when I was approaching SKBO. I wasn’t able to connect to the unicom but then again, the airport is elevated at 8359ft so I assumed I was too high? The API service was also working normally at the time.

Again yesterday. Changed A/C from 777 to 208. Didn’t load or use IFA. Reinstalled IF before this flight. This time into KMTH. Someone wanted screenshots 👇image image image image

Had the same thing on approach today into Seville (LEZL)! I was fully established on the glideslope but no ATC until around 5mn.

1 Like


Thanks for the reports, all of you!
The problem is that it seems intermittent? Have anyone discovered a reliable way of reproducing this?

Can you try a quick KPBI > KRSW ?
When I flew it today, the adjacent KFMY showed up at 27nm, and moved up the list as I got closer. But KRSW didn’t show until I landed.
Also, IFA RAAS call outs on approach were missing.
Just did another flt. Didn’t change settings on maps. That didn’t help.
KRSW showed up on comms list at touchdown. (When flight plan ended at destination. )

Haven’t found out how to reproduce it. However, it seems to be quite erratic on when the issue happens or not. E.g. on my approach into Tokyo I had tons of Unicom frequencies of airports up to 25NM away except RJTT. I was only able to tune into RJTT Unicom when I was approximately 6NM from the airport.

1 Like

I have made several flights into KRSW and can report the following:

  1. Using IFA or not has no effect.
  2. Using a flt plan or not has no effect.
  3. Using KRSW in the flt plan has no effect.
    But this screenshot shows something interesting. Notice airports listed that are in excess of 40 nm. The last listing is directly behind me almost 50nm. Also note my proximity to KRSW, and that the approach runway is not listed.

Despite several times of clicking on “no frequency “ to refresh the list, it did not refresh. Only when it finally decided to refresh, did KRSW appear in the comms list AND the list of approaches.

Any thoughts?