Unable to subscribe

I’m attempting to subscribe but when I click the one year subscription button, the app crashes. The one month button is not functioning and has the words error on it. I have updated my iPhone and deleted the app and downloaded again leading to the same result.

Will you please advise?

Captain Mark

Device, opperating system and app version are needed

Network connection?

Like Josh said, operating system and device would be helpful!

Try logging out of your current account with infinite flight, whether that’s Facebook or gmail.

Once you’ve done that, delete the app from the multitasking section and reload, try logging back in again. See if that works?

Same result

The volume button doesn’t help lol, do you already have a subscription? Have you had one before? If so try selecting the ‘already have a subscription?’ button instead.

Sorry volume that snuck onto the screen when I took picture. I have had a subscription before but currently do not.

Yes I tried and same result.

Can’t really propose anything else, I suggest contacting @philippe, looks like an a isusue with the app itself.

Ok thanks for your help sir and to all.

God bless!

Hi…any chance you have restrictions enabled?
Settings-General- Restrictions…and look if there is In-App Purchases is enabled

1 Like
  • Make sure you have a legitimate copy of Infinite Flight.
  • Make sure you are able to make in-app purchases on your device.
  • Make sure you have the latest iOS version.
  • Make sure you have the latest version of Infinite Flight.

  • If your device is jailbroken, this may cause the problem.

Try redeeming your subscription on the account website: https://account.infinite-flight.com/Account/Login

☝️ couldn’t said it better👏
If this all not help, try THIS stuff…

Bingo!!! The restrictions is what caused the issue. THANK YOU!

See you in the air.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.