Unable to hit OK in search bar/error when importing .flp files

The “ok” and “cancel” buttons are missing from the search menu, making it difficult to input waypoints from simbrief and FLPtoIF.

Also, i am unable to import saved .fpl from device, getting an error message when importing. I tried closing the game, clearing cache and nothing seems to work.

Here is a screenshot of my screen:

Device: Samsung Galaxy Tab S7
Operating system: Android 12

1 Like

try powering off your device (not the same. thing as turning off)


Sorry about this.
We’ve been able to verify & reproduce this issue and are working on a fix for it.


Hi. I have the same issue. Using Samsung Galaxy Tab S7+ with Android 12. Issue is resolved after a restart (cold reboot).
Also, I lose sound sometimes (but not consistent). Reboot resolves thia also.

1 Like

@Nefarious don’t you have some thing similar as a problem?

1 Like

Okay, we’ve found the issue. (Thank you @Jeno_Farkas for pointing us in the right direction!)

This is unfortunately a quite common issue with many applications & games since the OneUI 4.1 update. It doesn’t affect all devices, but a fair share it seems. The complication with this problem seems to be that Samsung’s OneUI 4.1 update introduces a resolution limit to games. This limitation has some pretty nasty and unwanted side effects with a ton of games, besides Infinite Flight.

There is a workaround however:

  1. If it is not already installed on your device, install Samsung’s Game Booster (Game Booster Plus - Apps on Galaxy Store)

  2. Go to “Gaming Plugins” → “Game Booster Plus” and tap the icon on the right side of the row that shows Infinite Flight & select the “High quality” option.

This should resolve any resolution related issues you may experience since the OneUI 4.1 issue.

We will have a look at our end and see if there’s anything we can do to counter this change. But we suspect that the fix will have to come from Samsung in the end.

Thank you!


Glad someone made a topic about this, since I was also considering on making a support topic regarding this issue. I’m having the same issues with the menu and ‘OK’ button missing on my Samsung Tab S7 on IF since a few days.

It makes it impossible to choose a callsign number or navigation waypoint or height (which also means no VNAV). I tried several things but was able to fix it just once with a reboot.

Thank you @schyllberg for posting a work-around. Definitly going to try this out right away. Hope it works.

I tried the app suggested above, but do not seem able to open it on my device. Therefore I cannot use this workaround 😥

Thanks, i followed those steps and things seem to have stabilised. Now (as briefly mentioned) i am recieving an error message when importing flightplans saved on my device.

As always i dropped a screenshot below as reference

Had the same issue, Samsung decided to hide game booster in the menu, and access the gamebooster plus after installation was really hard. Here is how I did it:

  1. In settings search for game booster settings need to enable shortcut bar

  2. When launching game find shortcut bar in the original navigation menu or if you use the gesture navigation than a little - almost invisible - handle like this :

  3. Once you drag that handle towards the centre of the tablet you get a menu bar on which you can tap the 3 dots and than game plugins, which is the puzzle icon top right corner:

  1. And here you can enable game booster plus:

  2. And than tapping its name you can go into the settings as @schyllberg mentioned before.

I hope this helps, Samsung hopefully will be better in these UI things…


Thank you so much for taking the time and explain this in such details. I got it to work out thanks to you.

It seems to work good for now.

1 Like

I’m glad you found it helpful. Not sure why Samsung decided to hide game booster plus so deeply in the system…

By the way I’m happy with what it does to the gaming experience: somehow everything appear more detailed and sharper with the booster, while having very minimal impact on the performance.

Thank you very much, after following the instructions and did some testing it seems to work just fine 🙂, i did meant to create a new topic i just couldn’t find if someone reported the same issue before.

My Log book isn’t looking pretty bc i tried many time before getting to the solution but now it’s all good. Thanks again.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.