Unable to go on live

I’m having issues accessing the live servers, it’s just loading forever, then logs me off, then I log in, then it says this:

I’m pretty sure it’s not my wifi because I can do stuff on the internet as normal, and I’ve restarted my iPad and the app. It’s been like this for 6-7 hours now.

iOS: 10.2
Device: iPad Air 2
IF Version: Most recent

1 Like

Probably a local CDN issue that will be resolved soon. A reinstall might help though if it’s just stuck.

I’ll try a reinstall now, see if that helps. Thanks

1 Like

It’s still the same, I’ll just try and wait a day or two. Back to being a non Live+ user for some time 😂

1 Like

Sounds like a CDN issue. Not much you can do then!


You could also try unplugging your wifi router and modem for a minute while the iPad power is off. The. After a minute, plug the modem in first and let it warm up until it indicates full connection status. Next Plus in the wifi router and let it warm up as well. Once both show full connectivity is established, turn the iPad on and launch Infinite Flight. That should fix it.


Unfortunately I waited out a few days and still hasn’t worked :/ Now I when I log into my google account to get my Live+, it just loads forever and never gives me my planes/regions…