Unable to connect to server

Hi,
I haven’t even touched IF in quite a long long time (almost a month now) and hence I thought today, I’ll try doing a short flight. So, I set up my flight plan everything until this…


I tried opening and closing multiple times. Still didn’t work.

I restarted the app and then tired…, still no

I did check my connection, it is running fine. It’s fast enough as well (80-90mbps)

Please help,
Thanks.

1 Like

Have you changed any of your WiFi or Cellular settings since you’ve last flown? If you are on WiFi, you could try resetting your router, after it resets, make sure you close Infinite Flight, stop it from running in the background and then relaunch the app.

I did do that. It is still giving the same not connecting error

Which version of Infinite Flight do you have installed and did you recently update IF? If so, you might have to back up your replays then try reinstalling Infinite Flight.

It’s the latest at the moment [21.7]. I’ll try reinstalling as you said.

1 Like

Hello, have you tried reinstalling the app? Or signing out of your account and signing back in? Also check future topics, it may be a server issue…

2 Likes

I did check and there were no server issues. And hence I created this topic.

I’ll reinstall the app as both of you said 🙂

Hey, l don’t think this needs an app reinstall. It looks like your connection is likely blocking the ports we need to connect to the multiplayer servers.

Are you using WiFi or Cellular? Who is your ISP? (you can DM me if you’d rather not share in public). Thanks!

3 Likes

Hey Cam,
I guess you are right. I did reinstall the app like @Levet and @Lufthi456 said and the issue persists.

I’m using Wifi and wdym by ISP? Like company name or something else?

1 Like

ISP is your provider yep. We have a few known providers that have issues connecting with our network so it would be good to check

1 Like

Ah ok. My ISP is Airtel (it’s an Indian company). I have been using it forever tho.

Never had an issue

Hey!

If you’re from Mumbai, Airtel has been down today, in quite a few areas in the city - both telecom and internet services. They just sent an SMS about an hour or so ago saying their services are being restored normally.

1 Like

I’m not from Mumbai haha. Thanks tho

The most likely cause for this issue is that your ISP is using IPv6 exclusively, which seems to be a recent change for Airtel. Our multiplayer servers currently support IPv4 only.

We have updates in the pipeline for early next year that will support IPv6.

In the meantime, a few options you can try:

  • See if there is a setting in your router to force IPv4
  • Use a VPN

Sorry about this! If this isn’t something you’re able to get working, drop me a DM.

3 Likes

How exactly do I switch the thing?

I’ll try it with a VPN tomorrow

Unfortunately that varies a lot by router and internet provider. It’s probably best to contact your ISP to ask about that.

Let me know if you do manage with the VPN

2 Likes

Hi, VPN works fine for flying but sucks for controlling. Like It makes things very slow and It won’t be able to load the traffic at Zurich for example.

I control FNF hubs often and it will be a huge bummer there :(

VPNs add an extra layer of latency so that’s not surprising; I would choose a VPN that has a data center near your physical location to reduce latency.

As mentioned, we do have IPv6 implementation planned for early 2022, but there’s nothing we can do on our end to help now other than to recommend these workarounds. Sorry!

2 Likes

Thanks anyways, Cam! At least I can fly now.

2 Likes

Glad it at least helps with that :) Enjoy!

1 Like