Unable to connect to global server and air spawning

Hi,

Recently whenever I have tried to spawn into any server, any location, even using different graphics settings, I just spawn in the air and then my plane falls to the ground and “crashes”. This is the same on solo.

Also, I have an issue connecting to the “global server” it is always red and sometimes takes a few hours of flying to turn green and then still goes back to red sometimes.

This is only a recent issue and I have had no trouble with global until the last two-ish weeks.

Global Server is red and message reads “No additional information”… However, all else is green.


Device Specs:

Samsung Galaxy S7 Edge.
Model Number: SM-G935FD
Android Version: 7.0
Baseband Version: G935FXXU1DQER
Kernel Version: 3.18.14-11104523

Remaining phone memory: 4.6 GB


Latest version of Infinite Flight on the Play Store

Current Graphics Settings: Everything is maxed out including airplane count, limit frame rate is on, automatic low
power mode is on

Application Permissions: Microphone and Storage (ALL permissions GRANTED)

Valid Infinite Flight Pro Subcription since October 10th-ish


Tried Approaches (Unsuccessful):

  • Restarting Mobile
  • Redownloading the app
  • Trying on a different device
  • Changing Graphics Settings
  • Restarting Wifi router

Link to video showing problem: https://www.youtube.com/watch?v=kqODqT4yTVg

1 Like

Something has to be wrong with your device if this keeps on happening. Have you tried backing up all your data and doing a factory reset of the device?

So you have tried on a different device connected to your account? May I ask what this device is?

1 more thing, if it is possible. Can you send us a recording of what is going on?

The other device was a Samsung Galaxy S6 Edge

1 Like

Thank you for that information.

1 Like

OK, I’ll try thanks!

Alright, I recorded a video, but it was a bit different this time, here’s how:

Usually when I spawn I fall for around 3-4 seconds then crash, in this, I kept on falling resulting in a violation. (first time it happened).

Link: https://www.youtube.com/watch?v=kqODqT4yTVg

1 Like

I have never seen that before. Well you have done everything you are supposed to do, but the last resort is a factory reset.
One last thing, you have never rooted your device, correct?

1 Like

Correct, I don’t recall rooting my device. Thanks for the help though!

I rather not factory reset to be honest :/

1 Like

I am experiencing a similar issue where global server goes green and red constantly, I have a strong WiFi connection and have been playing global without a problem over the past month

2 Likes

Let’s give it 1 last try. First, delete the app. THEN, reset your device via the settings application

I’ll give it a shot and get back to you ASAP, thanks :)

1 Like

Yeah, my WIFI is also super strong.

This is a known issue about the Global servers. Thanks for the report.

Regarding the whole “my internet is strong” thing.

Just because the signal between your device and router is strong, doesn’t mean the connection is stable.
The issues you are experiencing is caused by connectivity issues that could either be because of the app, device or router.

Have the router been restarted? Seems likes that’s one of the few things left.

3 Likes

Yes, I restarted the router just a while back.

I’ll try using my data.

2 Likes

Hm… works on my data…

Suspected it was something like that.
Reset the router is the next step :)

1 Like

I tried restarting the router though, it didn’t work.

Does your WiFi work on other applications that use it?

1 Like