Unable to change profile picture

Hey all, for some strange reason I’ve been unable to edit my profile picture. I want to have it as a selected image but whenever I try to use the picture is says 100% and never loads or changes. My Wifi is definitely okay, because I’ve just finished watching episodes of Family Guy on YouTube and scrolled through Instagram which have been both working fine.

Specs:
iPad Air 2
Latest iOS
Running Chrome app

Any idea of why this could be happening to me?

This belongs to #meta, not #support .


I have had the same issue some months ago. I have tried to upload the image I want with another device. For example, I was using my tablet but didnt work. Then I tried with my phone and worked fine:)


Make sure you wait some minutes for the picture to upload or even click Save Changes!! Refresh the page and should be fine. Hope it helps

1 Like

Hey man, just moved it to #meta. I really appreciate your answer. Thank you very much!

1 Like

No problem 😉 Let me know if it works!!

1 Like

I just tried a different browser, it’s worked now!

1 Like

Nice!! Problem solved

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.