Unable to Change Callsign

I was just about to go onto the advanced server but I needed to change my callsign. I was in a American 777 so I chose American 19 heavy. Then I got this come up on my screen.

1 Like

I have gotten this too. Please include decide and operating system.

Sorry I forgot, I think I just saw you flying at London btw
iPad Air
Latest infinte flight version
Non Jailbreak

1 Like

It happens to me aswell …

What I do is I load a online flight on IF , once in the flight , I press pause then click on callsign and change it then …

Works for me like this

1 Like

Ok I’ll try that

Exactly what is was going to say!

Did you just exit a previous flight and try to change your callsign?

1 Like

Yes this happened to me a couple of times. I solved this by coming right out and closing the app before restarting.

I can change it normally now

1 Like

Yep, known issue. If you close the app completely and reopen it, you should be able to change your call sign as normal

Ok glad to hear … Did my comment help ?

Yes but I just needed to refresh the game and it worked

Ok glad it worked

It happened to me too. All the advanced controllers who controlled me, this is the reason I was flying with Luftannsa cal sign for 3 days

I have this error as well on Android 4.4, along with losing the Unicom audio. I have to close the game and restart it after being sure it is flushed from memory. Hope it gets fixed.

Solved! Thanks everybody.

1 Like

I get same error. Try changing call sign after you spawn at airport. Works every time for me.

1 Like

I usually close the app down after each flight, as this refreshes the memory as well as saving battery life on your device. This seems to solve the problem.

1 Like

How do you close the app, David? as in tapping ‘back’ until it goes off your screen?? Mine will still continue from where I left off if I do that, until I switch the device off, then the app restarts.

Which device are you using?