Unable to access Global Server.

My line is good…but still sad about it cause you need internet connection to play on solo…i want previous version please…

Others have been able to gain access by hitting retry a few times. If that doesn’t work restart the device. If that doesn’t work start with a fresh download of the app.

I do everything you say,but still the same

What device are you using?

One of the solutions could be to turn off the Anti-Aliasing which is located in graphic settings. If that does not work, you should go to a less busier server.

Samsung galaxy J7(2016)

Shouldn’t be a performance issue…
Try resetting your internet connection.
Worked for me.
And if it pops up, just keep taking the retry button.

How is it not a performance issue…

Because your device is relatively new.
I’m pretty sure it has something to do with your internet or servers.

Did you try what I suggested?

If he wants previous version he needs to downgrade

You can’t do that with only your device, as far as I know. You need a computer.

He can do it through Itunes

The computer version.
Unless Infinite Flight didn’t support his device. Which it does.

@Ryan_Farell @anon36571935 - wrong place to debate things.

@Joel_Jok_Disun - as previous posts have suggested, it’s usually solved by restarting or repeatedly trying to get back in. Shouldn’t last long.

2 Likes

Ok. Sorry. Got abit off topic.