Trouble loading IF

Am I the only one having an issue loading the game?
It’s been happening for the past day or so. Its just on the wash screen with the load button.
Is there an update for this?

Do you have a strong internet connection?
Some more information would make it easier to diagnose the issue.
Have you restarted your device and/or reinstalled infinite flight?

Try to spawn in another aircraft at another airport.

Thank you for contacting support. We’re sorry you are having issues connecting to the live server. Please understand that while devices may be the same, the network configuration may be different between users.

Are you on a VPN by chance?

Please try the following to resolve your connectivity issue:

Reboot your device

This should always be the first step to resolve any issue. Sometimes the server issue is temporary so waiting a short period of time and/or rebooting may help.

Switch between network types (WIFI/Cellular)

If you are on wifi, try cellular if you can. If you are on cellular, try a wifi connection and see if it is any different.

Try a different network

For troubleshooting, try a different network and see if the results are different.

Toggle airplane mode

– Shut down IF
– Go into airplane mode on your device for 40-60 seconds
– Turn airplane mode off. This causes your device to reconnect to your network and solves the problem for some.

VPN or Proxy

Ensure you are not on a VPN network or behind a proxy. These will often block the necessary UDP ports for a successful connection to the live server.

Reset device network settings


Go to Settings > General > Reset > Reset Network Settings. This also resets Wi-Fi networks and passwords, cellular settings, and VPN and APN settings that you’ve used before.

From the Home screen, navigate: Apps icon Apps icon > Settings > Backup and reset
Tap Reset network settings.
If applicable, enter the PIN, password, fingerprint or pattern then tap RESET SETTINGS again to confirm.

Update wifi DNS settings

In some cases you may need to update your devices DNS settings on wifi to use google’s DNS.

Here’s how to change your iPhone’s DNS servers:

  • From the iPhone’s home screen, tap Settings.
  • Tap Wi-Fi. The available wireless networks in range of your iPhone appear, as shown below.
  • Find your wireless network in the list, and then click the arrow.
  • Tap the DNS field.
  • Delete the current DNS servers, and enter the new DNS servers. (If you enter more than one DNS server, be sure sure to separate the servers with commas.)
  • To use Google DNS, enter and
  • Re-launch IF


  • Open the Settings on the device.
  • Select “Wi-Fi”.
  • Long press your current network, then select “Modify network”.
  • Mark “Show advanced options” check box.
  • Change “IP settings” to “Static”
  • Change DNS1 to
  • Change DNS2 to
  • Press “Save” button, disconnect from the network, and reconnect for changes to take effect.

The DNS can only be changed while on WIFI.

When replying please help us out by ensuring you provide ALL of the following:

  • Your device model
  • Your infinite flight version
  • Connection type, cell/wifi. If cellular, please provide the network name (Verizon, T-Mobile, etc)
  • Country
  • Please list any of the steps above you have already tried and their results.

Thank you!

1 Like

Yes I have tried all of the above and it’s still just on the wash screen.
I did try loading it from my phone and it worked. Just not working on my iPad.

New York City, USA
Sprint data network and WiFi.

Mikhail Anthony

1 Like

If you are not on a VPN, the other most common is to reset your device network settings. This does not mean turn if off and on again, you have to follow the instructions above.


I’ve been unable to fly since yesterday.

I’ve rebooted my device a number of times, I’ve switched between WiFi and cellular. I’ve reset the network settings a few times and still nothing is working. Just want to find out what’s going on?

If you’ve tried rebooting your device with no luck and all of the other recommendations than delete the app, update your Operating System and reinstall Infinite Flight.

I just tried that and it’s still not working.

This is on your iPad or your phone?

Try signing out of Infinite Flight (Tap your username and select sign out) then rebooting your device. Relaunch and sign back in.

Worse case scenario is to backup all of your info to iTunes and do a factory reset.