Trouble assigning buttons on joystick

Hey guys👋

I seem to be having a bit of trouble assigning Commands on the Logitech Extreme 3D Pro joystick I got the axes ok but I’m having some trouble with assigning the commands I followed the tutorials but it’s not working

Thanks Guys. 😀✈️

Thanks sorry I thought I pressed support

No problem

Hey there @AviatorJack!


Its actually rather simple.

First, go into settings and into “Controls”

Then, go into “Commands” (Top right corner) and set up the controls to your preference!

Yes I know that but when I go into the Commands section it’s showing up on each command I press “Button 112”

Hmm, have you tried selecting the desired command and clicking on a button on your joystick?

I have this same joystick and I don’t have these problems.

Yep still the same

Could you provide a screenshot so I can take a look? @AviatorJack

I’m trying to reconnect to Live Flight Connect but it’s stuck on the loading page for the last 5 mins

1 Like

@AlphaSeven

1 Like

Do you have the computer and the device you’re playing IF on on the same network?

Yes I do .

Did you press “Enable live flight connect?” (Second last)

Yep I did .

So, what is your problem that you’re experiencing?

Buttons not responding? or LiveFlight not loading?

Both now 🙁

1 Like

have you tried restarting your router or computer perhaps? Or LiveFlight?

Yep both I tried

Hmm, try re-downloading the LiveFlight app is all I have left in mind…

Is your internet connection stable?