Thrustmaster T.16000M FCS Hotas - LiveFlight Connect

Hello community. I have literally just got a new hotas, the name of which you can see in the title, and I am trying to set it up with LiveFlight Connect. I have installed the drivers and everything already. The stick works fine with LFC, but the it doesn’t seem to register the throttle. As you may or may not know, the stick and throttle each have their own USB connection, so they are seen as two different devices. Is there a limitation of LFC where it will only work for 1 device, or is there a way to fix this? Any help is much appreciated.

You can only use 1 usb device on LFC. Had the same problem…

Incorrect. I can use two at once. I have a seperate throttle to my joystick.

K, and how please…?

The same way you connect your joystick up. Plug the USB in and then go to infinite flight and go to the “controls” section in menu, tap throttle and move the throttle

Don’t work…

That’s weird. LFC is definitely saying connected and everything right? Also what happens when you just plug in only the throttle

Are you using LFC on windows or mac?

1 Like

Me? I’m using it on Mac

I am using windows. It doesn’t matter guys. I’ve tried everything. Unless there is a way to manually tell LFC what device to take inputs from, I can’t do it. The joystick has a slider on it anyway, so it won’t matter too much, thanks for all your help.

i have been using the live flight connect for over a year until one day when it suddenly stopped working for a reason unknown to me. i have tried everything and i dont know whats wrong. the live flight connect just wont work. please help me!

Hello!

Try these steps to see if they will work;

  • Uninstall and re-install LiveFlight Connect on your computer

  • Confirm that Infinite Flight Connect is enabled on your device

  • Uninstall and re-install Infinite Flight on your device

If these steps don’t work, then could you please elaborate some more on what is not functioning with LiveFlight Connect or Infinite Flight
Thanks!

thanks a lot for your reply

here’s what had happened and how i got into this,

LFC stops connecting with infinite flight.
i tried uninstalling and reinstalling Infinite flight. yet of no help.
so I uninstalled the LFC.
tried reinstalling it again, but it just did not reinstall. i tried disabling the internet security, but still it wont get installed

Possibly Infinite Flight Connect is not enabled on your device.

Hop onto Infinite Flight
Go to Setting -> Scroll till you see Infinite Flight Connect -> Enable it

Most likely an issue with your firewall settings

If it is an issue when you are trying to download it, go into your internet settings and (depending on which browser you are using) make sure you are allowing downloads

If it is an issue installing, go into your pc’s firewall settings, try and find LFC, and unblock it.

If you are still having issues, I’d recommend contacting @Cameron (Live Flight Connect creator) to seek further help
Good day :)

You also have to allow the app to have access to private and public network devices otherwise it will not connect

yeah that thing is enabled, but thanks!
good day :)

1 Like

will check the firewall settings as am unable to install. thanks that should help.
good day to u too :)

1 Like

tried disabling the firewall and other internet security/antivirus options, but still not able to install LFC.

Hold on I’ll PM you ;)