Thrustmaster Boeing TCA yoke and throttle

Thank you very much for a detailed explanation :) I think I will have to try both of these methods out.

Yes, I have seen that the new yoke has USB-A and USB-C in the other end. The same goes for the throttle that comes with it. So you have the option to plug either side into the hardware and the other to a PC/raspberry.

Take care :)

1 Like

It was a pleasure to help you. If you need anything, I’m at your disposal. If the topic closes, you can talk to me in PM.
Good weekend Jonas 🙂👋

2 Likes

I appreciate that 😊 Thank you very much. Have a great weekend 😀

1 Like

Testing the Boeing Yoke.


On iOS, using a Raspberry Pi with IFJoystickPI.


On Android, using a USB-C/HDMI hub.

The yoke is absolutely beautiful and feels great!
It’s huge though, so you really need room both on and in front of the desk it’s clamped onto.

When trying to map as many functions as possible from IF, I found some issues.

What I found so far:

Connecting it all:

Both the rudder pedals (sold separately) and the throttle quadrant can be connected to the yoke.
That leaves you with just one USB connector to connect all three devices at once.
That works fine with a PC or an XBOX, but not with a Pi or a hub.

When using a Raspberry Pi, all three devices need to be connected separately in order for them to be detected by IFJoystickPI and function correctly.

When using a USB-C/HDMI hub on Android, the yoke and throttle quadrant need to be connected separately and the rudder pedals need to be connected to one of the other two devices. Otherwise the pedals don’t work.

Mapping functions:

This device has two controls that make mapping functions to buttons very difficult and even impossible.

Yoke:

On the yoke, the gear lever is always “on” in the “Up” position.
Every time you try to map a function to a button, the gear hijacks what you are trying to map.
This issue is easily solved by putting the gear lever into the “Down” position.
After you do that, you can map functions to all buttons.
At least when the Throttle Quadrant hasn’t been connected yet, otherwise it’s impossible.
More about that below.

Throttle Quadrant:

This is another story though.
It has a three-way switch that is always “on”.


Every function you try to map is hijacked by whatever this switch is set to.
There doesn’t seem to be a way around it.
This makes mapping other buttons impossible.
This device can’t be connected when trying to map everything to the yoke, otherwise the selection switch will hijack everything.
The trick is to connect the quadrant AFTER mapping functions to the yoke is done.

On android I was able to map Reverse Thrust to the reverse thrust lever.
It seem that when you’re quick enough, mapping can be done.
It’s a bit hit or miss, but I’m still testing, so I might find that other buttons can be mapped as well.

So far the throttle is the only function on the throttle quadrant I’ve been able to map.
The levers for Spoilers and Flaps don’t work because these controls are buttons in IF instead of levers/sliders.

On the yoke I was able to map Roll, Pitch, Flaps, Trim, Autopilot, Brake, Next & Previous Camera and Reset Camera.

I’m still having issues getting the HAT-switch to move the camera correctly. Right now the axes are inverted.

Rudder Pedals:

I’ve also been able to map Yaw to the Rudder Pedals I ordered with the yoke.

The pedal brakes don’t work though.
I was able to map “Brake” to one of the pedals, but then the brakes are “on” when a pedal isn’t pressed and “off” when it is pressed.

To Be Continued…

That’s it so far.
I’m still trying things out.
I’ll update this post when I have more information.

UPDATE #1:

During more testing I’ve been running into more issue when the devices are
connected to a USB-C/HDMI hub on Android.

Somehow I keep loosing sound.

It turns out that when the yoke and throttle quadrant are connected separately, they are using the same button numbers, which makes mapping all the buttons impossible.

Still testing.

UPDATE #2:

After some more testing I found that when you set the three-way selector switch in between two selections, it goes off.

That means that when the devices are connected using a Raspberry Pi, all other buttons can be mapped!

That’s such good news!

I was able to map “Brake” to the left trigger of the yoke and “Parking Brake” to the right trigger.
Unfortunately that only worked the first time.
After I had tried to map “Brake” to the rudder pedals again, I wasn’t able to map it back to the left trigger of the yoke.

Still trying to figure out what on going on there.
I had to use “Parking Brake” instead of “Brake” as a workaround.

Using the Pi, I was able to map the following:

Yoke axes:

  • Roll
  • Pitch

Yoke buttons from left to right:

  • Parking Brake
  • Autopilot
  • Flaps Down/Up
  • Trim Up/Down
  • Camera Movement (still inverted)
  • Flight Path Vector
  • Camera Previous/Next
  • Zoon In/Out
  • Camera Reset
  • Landing Gear

Rudder Pedals:

  • Yaw

Throttle Quadrant axes:

  • Throttle

Throttle Quadrant buttons:

  • Reverse Thrust
  • Spoilers Toggle
  • Pushback
  • Auto Start
  • Strobes
  • Landing Lights

Known Issues:

  • HAT-switch is still reversed
  • Unable to map “Brake” again
  • “Landing Gear” is toggled by moving the lever up and down again

Still testing…

8 Likes

Thank you very much 😊

2 Likes

Yes thank you!!

1 Like

👍😁👏 very nice!
@Jan how did you do to mirror on your tv?

I’m using a USB-C/HDMI hub to connect my Android tablet to my 43 inch monitor.

1 Like

I was able to do some more testing and updated the post above accordingly.

1 Like

Any updates since your last check? Seems there are several of us interested in 3rd party hardware, and you have done such in-depth testing here. Also, the look inversion issue is a global issue that impacts controllers as well. There is not a current option to invert Horizontal movement, which isn’t an issue if you use the devices itself with touch.

No, not yet.
Haven’t been able to.
Still planning to though.

How can i connect the joystick with infinite flight? Does a joystick still work with infinite flight?

search the community you will find a couple different posts. Overall, you need to use a 3rd party app with iOS I believe as Native joystick to USB has not been tested to my knowledge; Android can hook joystick up directly via USB connector. Otherwise, you will need to use Infinite Flight Connect, live flight connect (i have heard), or this new raspberry pi IFJoystick (but you need a raspberry pi),

can i use it on IPad without any other devices?

You’ll need some kind of device - like a Mac or PC or Raspberry Pi - since iOS doesn’t natively support third-party joystick connections.

If you’re using a Mac or PC you’ll have to download a free app called Map Connect to use a joystick with Infinite Flight.

ok, thanks for the help, how much is the lowest level Rasberry Pi that will work with that?

Check this out:

As far as which computer to use…I’m afraid someone else will have to handle your query. I’ve never used a Raspberry Pi before. 😅

Due to chip shortages there are (almost) no Pi computers available at the moment.

Hello @Jan , how are you? I hope fine. I bought a Rudder just like yours. Yesterday I was reading your latest updates and wanted to know if today you managed to apply the brakes on Rudder. Did you actually manage to set the brakes on both pedals?

Hi!
I haven’t been able to test more, unfortunately.