Thrustmaster Boeing TCA yoke and throttle

Testing the Boeing Yoke.


On iOS, using a Raspberry Pi with IFJoystickPI.


On Android, using a USB-C/HDMI hub.

The yoke is absolutely beautiful and feels great!
It’s huge though, so you really need room both on and in front of the desk it’s clamped onto.

When trying to map as many functions as possible from IF, I found some issues.

What I found so far:

Connecting it all:

Both the rudder pedals (sold separately) and the throttle quadrant can be connected to the yoke.
That leaves you with just one USB connector to connect all three devices at once.
That works fine with a PC or an XBOX, but not with a Pi or a hub.

When using a Raspberry Pi, all three devices need to be connected separately in order for them to be detected by IFJoystickPI and function correctly.

When using a USB-C/HDMI hub on Android, the yoke and throttle quadrant need to be connected separately and the rudder pedals need to be connected to one of the other two devices. Otherwise the pedals don’t work.

Mapping functions:

This device has two controls that make mapping functions to buttons very difficult and even impossible.

Yoke:

On the yoke, the gear lever is always “on” in the “Up” position.
Every time you try to map a function to a button, the gear hijacks what you are trying to map.
This issue is easily solved by putting the gear lever into the “Down” position.
After you do that, you can map functions to all buttons.
At least when the Throttle Quadrant hasn’t been connected yet, otherwise it’s impossible.
More about that below.

Throttle Quadrant:

This is another story though.
It has a three-way switch that is always “on”.


Every function you try to map is hijacked by whatever this switch is set to.
There doesn’t seem to be a way around it.
This makes mapping other buttons impossible.
This device can’t be connected when trying to map everything to the yoke, otherwise the selection switch will hijack everything.
The trick is to connect the quadrant AFTER mapping functions to the yoke is done.

On android I was able to map Reverse Thrust to the reverse thrust lever.
It seem that when you’re quick enough, mapping can be done.
It’s a bit hit or miss, but I’m still testing, so I might find that other buttons can be mapped as well.

So far the throttle is the only function on the throttle quadrant I’ve been able to map.
The levers for Spoilers and Flaps don’t work because these controls are buttons in IF instead of levers/sliders.

On the yoke I was able to map Roll, Pitch, Flaps, Trim, Autopilot, Brake, Next & Previous Camera and Reset Camera.

I’m still having issues getting the HAT-switch to move the camera correctly. Right now the axes are inverted.

Rudder Pedals:

I’ve also been able to map Yaw to the Rudder Pedals I ordered with the yoke.

The pedal brakes don’t work though.
I was able to map “Brake” to one of the pedals, but then the brakes are “on” when a pedal isn’t pressed and “off” when it is pressed.

To Be Continued…

That’s it so far.
I’m still trying things out.
I’ll update this post when I have more information.

UPDATE #1:

During more testing I’ve been running into more issue when the devices are
connected to a USB-C/HDMI hub on Android.

Somehow I keep loosing sound.

It turns out that when the yoke and throttle quadrant are connected separately, they are using the same button numbers, which makes mapping all the buttons impossible.

Still testing.

UPDATE #2:

After some more testing I found that when you set the three-way selector switch in between two selections, it goes off.

That means that when the devices are connected using a Raspberry Pi, all other buttons can be mapped!

That’s such good news!

I was able to map “Brake” to the left trigger of the yoke and “Parking Brake” to the right trigger.
Unfortunately that only worked the first time.
After I had tried to map “Brake” to the rudder pedals again, I wasn’t able to map it back to the left trigger of the yoke.

Still trying to figure out what on going on there.
I had to use “Parking Brake” instead of “Brake” as a workaround.

Using the Pi, I was able to map the following:

Yoke axes:

  • Roll
  • Pitch

Yoke buttons from left to right:

  • Parking Brake
  • Autopilot
  • Flaps Down/Up
  • Trim Up/Down
  • Camera Movement (still inverted)
  • Flight Path Vector
  • Camera Previous/Next
  • Zoon In/Out
  • Camera Reset
  • Landing Gear

Rudder Pedals:

  • Yaw

Throttle Quadrant axes:

  • Throttle

Throttle Quadrant buttons:

  • Reverse Thrust
  • Spoilers Toggle
  • Pushback
  • Auto Start
  • Strobes
  • Landing Lights

Known Issues:

  • HAT-switch is still reversed
  • Unable to map “Brake” again
  • “Landing Gear” is toggled by moving the lever up and down again

Still testing…

9 Likes