The reason to why some user's app is crashing and how to temporarily fix it


Since the last update, I have noticed many people reporting that their app crashes on launch. A lot of them speak Arabic and other languages that don’t use the Latin alphabet, such as Japanese, Thai, Korean, Chinese, et cetera. I thought that was interesting so I tried to change my iPad’s language to Arabic and launch Infinite Flight. The app crashed like many people have been reporting. I then tried it in Japanese but the test was not conclusive. Whereas, the Arabic test happened one hundred per cent of the time.

After many tests I concluded that languages without Latin characters in it (such as Arabic) crash when you launch Infinite Flight.

So, if your app crashes on launch and you have a language that doesn’t use the Latin alphabet (such as Arabic), please change your iPad (or iPhone’s) language to English to solve the problem. I will update this post as soon as Flying Development Studios have corrected this bug.

If you need help changing your device’s language visit for more information.

If you see others having this problem, please give them the link to this post.

Thank you :))


Wow, great find! @matt

1 Like

It’s awesome Joe! Bravo! I would have never found this…

But how does the language affect IF? My Iphone is in French and it works!

1 Like

Just “like” is not enough here, Well done mate, fine example of “thinking outside the box”.

1 Like

Bug reproduced, I changed my iPhone 5S’s language to Arabic. Attempted to launch IF, and it crashed almost immediately, running the latest release of course.

1 Like

I tried changing language to Arabic and it worked fine. iPad Air;Latest version.

Awsome job joe, well done.

1 Like

Ya me too did the same

Great find and thanks for all the details. I am looking into this since this is most likely our new text rendering system that still have a few corner cases for non-english locales. Make sure to point ppl who are experiencing the issue to this thread.


Glad I could help you :)

Why does this feel like such a flashback to the “Inifnite power” texting error?

Quick update on this bug; we tracked down the source of the problem and found a way to fix it. Had nothing to do with the text rendering stuff; it was a low level framework we updated that introduced an issue with locales that have a different calendar system.

We hope to push a hotfix this coming week.


Great to hear Philippe :)

Even I am facing the same problem but strangely it doesn’t work with the language part…

This bug should be fixed in the latest update for iOS (Android as well?), please post here if you’re still having issues with this.

1 Like

It came out for iOS within the last 20 mins.