The future for Android users

I am not in Open Beta but I am reading the issues that android users are having. I wanted to remind android users, that the requirements were raised for 21.1 to Android 7.0, I want to remind folks that Phillipe in the last twitch cast also said that at some point this year, they will raise the requirements again for Android, I wish Phillipe would clarify this more as people might start preparing to get more up to date devices. I just got a Samsung Tab S7, hopefully I will be ok for the near future.

2 Likes

As long as your device can reach the requirements stated here you should be good for 21.1. Iā€™m sure Infinite Flight will give us updates when they know for sure what the next requirements will be :)

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.