"The file couldn't be imported" message when retrieving saved .fpl

Hi there!

I’ve searched throughout the forum or perhaps I wasn’t looking hard enough regarding solution to this issue?

Importing saved .fpl always prompted IF to show: “Error. The file couldn’t be imported”.

I’ve saved a dozen of painstakingly-made FPLs using the share button from the map in every way possible, to google drive, email, internal drives, even to whatsapp, but none worked when I tried opening them in IF. It’d be nice to be able to use the intended button without workarounds…

Is there an extra set of apps that I should have in my phone for this to be able to work?
Anyone have the same problem and solutions?

Device details

Xiaomi MiMax 2
Android 7.1.1 (Nougat), MIUI 11
Qualcomm MSM8953 Snapdragon 625 (14 nm)
Octa-core 2.0 GHz Cortex-A53
Adreno 506
64GB 4GB RAM eMMC 5.1

Recent fpl exported from my Infinite Flight:
FlightPlan_SAEZ_SBRJ.fpl (13.3 KB)

Any help appreciated, cheers yall!

1 Like

The .f-l file itself is ok.

But it might be that there is a hiden extension behind the .fpl
If shared via google.drive google adds .xml making the file type assignment for IF invalid.

image

1 Like

Yeah, I am not able to open it because of the .xml extension. At least using my devices file explorer. Once I removed the .xml I was able to import it.

2 Likes

Yea I realised the .xml part and have deleted it, but it’d still won’t import.

I’m actually quite happy to recognise the screen shot of my flight plan above but also sad at the same time lol! It’s there, just have to find what’s wrong on my side.

Maybe it’s how the app interacted with the device and any xml files being output out of IF gets modified? Or my installed IF have problem with the explicit intent filter to open that extension type.
So I shall be uninstalling and re-installing and will report back soon!

Think I’ll give it a rest today and try again tomorrow, it’s 02:00A.M. in this part of the world, headin’ back now :p Thank you so much for your help, cheers guys! @Major-Tom @Chris_S

1 Like

Update:

Tried reinstalling Infinite Flight but to no avail, tried exporting the fpl in all sorts of ways, even tried modifying its content also making sure extension is correct, still can’t import them.

But seeing proof that it works on other phone makes me think that there’s something wrong with the way my phone interacts with Infinite Flight.

Thank you guys for responding so fast and helping me out, but the problem might be internally related with my phone’s system. So for this, I’m afraid the nearest solution to my skill set is to get a new phone and stop pursuing it to work with current phone. Well until then, Capt JJ signing out - someone may close this thread if they deem it necessary, again thank you and goodnight, cheers!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.