Terrain issues... (black floor)

Posting pics with absolutely no info will not help us figure out where the issue is coming from.

My guess is that happens due to the scenery cache being corrupted. Reinstalling the app should solve it at least temporarily.

8 Likes

Sorry about that Philippe, I had posted all the information on a separate
header “Black Screen, airport didn’t load.” I forgot to copy the info
across under this post. Will add it, my apologies.

Khamal E Georges
News Anchor/Multimedia Journalist
CNC3 Television - Guardian Media Ltd.

3 Likes

Just FYI Phillipe happened to me on a 8 hr flight i was on the new iPad Pro no other tabs were open excellent WiFi and high rendering could that be why

1 Like

I’ve had this problem twice on my iPhone 5SE, and it doesn’t go away until you end the flight. Is this created by brightness levels being to high for a long time, not enough memory, so it cuts back?

1 Like

I couldn’t find the root cause of the issue since it is so hard to reproduce. From what I can gather IF just suddenly stops refreshing the terrain meaning 2 things could potentially be the cause:

  • connection is unreliable.
  • the scenery download/processing threads (we have one per processor core on the device) get “stuck” so scenery can’t be refreshed.

I tested the first one locally by turning off my connection for a while and then back on, everything was refreshed as expected as soon as the connection is available and good.

For the second one, it might (this is highly speculative) be dependent of where you fly. It would be great to confirm this: does this happen always in the same location even after restarting the app and redoing the same flight? does it happens in the same location after reinstalling the app?

Anyone who can provide with a definite way to reproduce this 100% of the time will have my eternal gratitude :)

9 Likes

I was on a flight from Dubai to Beijing have amazing WiFi

Make sure you reloaded the app, and if needed, delete and redownload.
If you do redownload and you cant sign back in go to this Support topic. Don’t make a new topic.

This happened to me from New York to Luxembourg around the Boston area. I tried the flight for the first time and the land was just blurred out. I tried again and it worked. Then it happened again the third time. It also happened going to Vegas from Boston.

Last night I flew from KDEN ro EHAM, overnight. In the night my connection was lost, but happily the scenery did load when I did connect with the internet. But at the moment I wanted to land I flew straight into the ground and crashed (just a normaal landing, not hard). How is it possible that the scenery load, but I just fly into it?

1 Like

Just encountered this problem ; was flying from UHWW (Vladivostok) to RJTT (Tokyo). And when I reached the Japanese coast, the terrain (Or water ; not sure) disappeared

IPhone 6
iOS 11.0.3
Not jailbroken

This is the first time happening. Shall do the same flight soon and shall report here if the same problem persists.
Also, I had everything green in the Status bar in the top right

1 Like

Just completed my second flight.
And, no issues !
I think at the time, my connection timed out for a brief moment then returned causing the Terrain to glitch.

Thanks

1 Like

Great to hear! Have fun and see you in the global skies!

2 Likes

Had this issue when landed at KLAX. Used autoland. Had 2 connection issues during the flight from RPLL (12h++ flight).

@philippe,

I may have found a way to reproduce this bug.

It seems that this is happening when crossing the regions between the 15m resolution and the 500m resolution satellite imagery.

The results show on this thread back up this theory. Notice how all the flights completed are crossing the boundary line between the 15m resolution and the 500m resolution. I have been able to reproduce this theory with 2 test flights.

This is an image from my first test flight - Moscow to Los Angeles, heading northbound over Greenland.

!
This is an image from my second, 22-hour test flight from Hong-Kong to London EAST bound (over Japan, Alaska, USA and Iceland)

The result seen is very similar. Also, notice how only the scenery that’s being rendered on the second image is the elevation! To sum up, here is how to repro:

  1. Open Infinite Flight

  2. Set an aircraft, and departure airport of your choice.

  3. Set a flight plan that crosses the regions between where the 15m imagery and the 500m imagery meet.
    i) I haven’t had the time to test this, but try going above or below 60 degrees longitude (to see if the lack of elevation plays a role when reproducing this bug)

  4. Fly the flight plan and observe results above.

System Info:

iPad Pro 12,9", iOS 11.0
Infinite Flight Version 17.4.6498.31078

Potential Problem?:

Infinite Flight uses TerraColor Imagery for the 15m coverage, what does it use for the 500m coverage? Could the fact that you’re transitioning between two independent sources of satellite imagery lead to the terrain issue?

11 Likes

Just finished a flight from Hong Kong to SFO no connection issues. Everything was fine until final approach when there was fog and 30 seconds after it appeared the scenery(including the moon and stars) went black.

1 Like

This looks like a different issue as the mountains remain intact, but as Phillipe said;

Same terrain issue happened to me again after a long flight, no airport to land 😢

Just flown a 13hr flight and had the same issue for the last hour or two on approach.

iPad Pro
iOS v10
Latest update.

Poss due to poor wifi at home (though had a green tick on the app). After flight deleted app and reloaded and issue resolved.

3 Likes

This is caused by a Corrupt terrain file. A Re-install fixes it!