Sun and Moon not rendering in screenshots

G’day everyone
I was trying out taking moonshots using the replay screenshot feature, and for some reason, the moon and the sun haven’t been rendering in the screenshots using the built-in screenshot function, however, when I take a normal screenshot with my device, the sun and moon seem to render in fine. Here’s what I mean:



This is a photo taken with the built-in screenshot function. As you can see, no moon visible.



This is taken using the regular screenshot function on my device, this time the moon appears. This also occurred when I tried to take a photo with the sun in it. I’ve never had this issue before, and I’ve been able to take moonshots and sun shots before without this issue occurring. I’d like to know if other people can try to replicate this on their devices. Thanks :)

7 Likes

Hmm interesting. Have you tried reloading the app?

1 Like

Try changing the time when the moon or sun is in the position you want to take the photo and then come back at the same time, it should work, I always do that

1 Like

It has to do something with the time or something.

All I know is it has to do with something. I’ve asked and didn’t understand what people were saying but what I got was just take a screenshot using the device it self. (Eg iPhone X you would use volume up button and sleep button)

1 Like

Just tried reloading, and it’s working with the moon now, but I still can’t get the sun to render. For context, here are two screenshots of the sun taken with and without the built-in screenshot feature.

1 Like

I have had this happen to me and a few other people before. It seems to be quite random and show no signs of a pattern for me. I know it can be frustrating sometimes.

Here’s an example, the moon had rendered in IF but not in my camera roll 🤷🏾‍♂️

3 Likes

So… it’s just random chance then? Bugger, I’ll come back tomorrow and see if it’s better by then. Oh well, thanks for everyone’s help.

1 Like

If a significant amount of time elapses between you positioning your camera and taking the shot with the in-game screenshot function, you can expect the moon or sun to move a bit from the desired location or completely out of frame in the resulting photo. If you haven’t tried already, look at the time before you start moving the free cam to get the right angle, and then before you take the shot, adjust the time back to that initial time and see if it fixes it.

1 Like

That’s not the issue here - I know what you mean but this is different. I had it happen to me a couple of days ago. I was positioning a SWA 737 in front of the moon at cruise and took a few photos all from slightly different angles (double tapping, taking screenshot, double tapping, moving the free cam, …)

Each time I took a screenshot the moon was fully in view. I finished my flight, went to camera roll, and I had: moon, moon, no moon, moon :) A strange glitch but as has been said above no real rhyme or reason. Irritating but it is not a constant occurrence thankfully.

Also I have an IPad Pro 11’ not yet on iOS 14

The solution here is zoom out, because if you zoom in as max you can, moon just move away from plane so fast. Remember, moon and sun moving if you have a paused your replay.

Hi @Shafran,
That’s not the issue. As @Rock77 explained above, the issue is with the sun and moon not rendering properly, even though they are in full view when the screenshot it taken.

1 Like

But otherwise, sun and moon perform moving even if you replay stopped.

@ToasterStroodie, and @Shafran I don’t think that’s the issue here, look at this screenshots you can see the sun/moon in one but not the other and both are lined up fine. Not to mention that I think Oli has enough experience in the sim to not lose the sun because he’s zoomed in too much 😉

3 Likes

You’ve got this, anyway i’m trying my best to help this guy.

I’ve tried for a few minuets here to get this to happen to me and with no luck, guess it’s just some random bug, too bad, looks like you had some bangers lined up there, hopefully you can go back and catch them soon enough.


Here is moon moves… i’m hate that.

This has happened to me before. Try taking multiple pictures, that usually works for me. If not, exit the replay and try again

This is a known defect and is being worked on. It has to do with the positioning and how the high res screen shots are taken. There is no ETA for a resolution.

4 Likes

Once you set the angle move the time, and then take the screenshot. Sorry if I’m not being specific, give me some minutes and I’ll share a vid. 🙂

Thanks Chris. Can a moderator please close this now? :)