Sudden screen brightness change on IOS

I read on an older thread on the community that an IOS feature causes the screen brightness to dim a lot if it overheats.
While I understand the safety measures taken by apple for its users, my phone barely overheats on Infinite Flight and I find it very frustrating to find myself with a very dark screen on short final at night time.
I’d like to ask if there’s a workaround for this issue that hasn’t been allowing to me see a single thing while taxiing at night (with 100% brightness) for a long while now…

Thanks!

3 Likes

If you’re asking why the screen dims automatically, you most likely have auto-brightness turned on. You can turn this feature off by heading over to Settings -> Accessibility -> Display & Text Size -> Auto-Brightness.

Hope this helps :)

1 Like

Howdy! Go to settings > accessibility > display & text size > auto-brightness. Try turning that off and let us know how it goes.

I have the same issues though. Its getting displayed that it’s the same Brightness but it still dims it down

Hey,

If this is more than an auto-brightness issue, I’d suggest doing more than just the steps provided by the first two responders. If it is an iOS feature causing screen brightness to dim when the device is under stress, reduce some of your performance aspects. You may wish to reduce your graphics settings for example.

To better help you, may I ask what device you use?

Patrick

I’ve been experiencing this with my new iPad as well. I knew how to do it a while back on my phone, but forgot how on my iPad and never cared enough to change it. Now that you asked, and people answered, I have the solution, thanks!

In my case it’s an iPad Pro 2018

That’s a relatively new and well-performing device. Have you confirmed this is a non-auto-brightness problem?

I will look into it after I landed but I am pretty sure I turned it off

I don’t think this is an auto-brightness issue. I use a 2019 iPad Pro and have encountered this dimming “issue” before. I think I understand what op is talking about because I usually experience this with prolonged use, or if I turn the frame rate limiter off. I too have auto-brightness turned off which is why I doubt auto-brightness is the problem here. For me personally it’s not a big deal because it’s not a drastic drop in brightness (but still noticeable) and will usually brighten back up within a reasonable amount of time.

2 Likes

First things first - if @Maximilian1805’s iPad is being throttled by iOS, which causes the screen brightness to dim, auto-brightness has no effect on the issue. Secondly, to answer the original query, no, you cannot disable this iOS throttling feature. It’s there for the protection of your device. Reducing your graphics settings is the only workaround not to get this issue.

1 Like

Right. So auto-brightness is more for the light in the room, etc while this is a protection feature to help devices not overheat?

That is correct. Autobrightness adapts your screen brightness to the surrounding light. This iOS throttling feature dims the brightness in order for the device not to overheat which may cause damage to the hardware inside the case, like the CPU. This dimming happens when the device’s temperature is at around 40 degrees celcius or 103 degrees fahrenheit.

Hi there, yes it’s in fact more than an auto-brightness issue, I use an iPhone XR which is actually less than a month old. IF works perfectly fine with it aside from some minor lag in detailed cockpits and lots of traffic. I hope you might have an idea on what to do :)

I understand, thanks for the info!
Edit: the main reason I opened this thread is because considering my iphone is new and the XR is a relatively great performing model, I don’t understand how it has to take such measures in account so easily. I’ve been running with all graphics maxed out but I should try to reduce the traffic count I suppose.
edit 2: one last thing to take in account is that it dimmed at night at an airport, even with only one traffic about… which i find a little absurd for an “overheating” cause

1 Like

I understand where you are coming from, but this iOS throttling feature is not something that Infinite Flight has control over. It’s there for the protection of your device and is implemented by the guys at Apple themselves. Either way, glad I could help, take care! :)

1 Like

Thank you! Take care!

1 Like

It’s true. The heating is higher if it is muffled in a device protection.

Basically it’s an apple thing

Screens generate some heat, but on ipad when your chip is working hard on making sure your IF experience is amazing with close to full brightness heat can’t escape quick enough, so the OS dims the screen so that the “I’m overheated let me chill” screen doesn’t appear, as I would guess this is 100 times more annoying.

The only things you can really do to combat this is take your ipad out of the case, lower your graphics settings and limit background tasks like playing music.

1 Like

My screen does this also on my Samsung Tab S4
and my “Adaptive” screen brightness or auto diming is turned off. The device also does this when cool not warm or hot and with external power connected.
It is a mystery to me , but fortunately is is only a very slight dimming. Can’t find a solution.