Subscription issue

Hello, I renewed my subscription for Infinite Fight for 6 months, but now the problem is that money for 6 months has been deducted and it does not show that I’m subscribed. It still shows “Get Pro” button instead of showing me my profile.

Device : iPad Air 4th Generation
I have used the same iCloud account as before
My current call sign : Singapore 121
Community Forum Account : AvioBird777350

Kindly assist me.

Have you tried to reboot your device? Close Infinite Flight and turn you device off and back on. This will solve most common issues. Then re-launch Infinite Flight.

1 Like

Sure, I’ll try rebooting !! BRB…

Edit: No, nothing…still shows “get pro”

Try this:

  • Tap “GET PRO”
  • Tap “I already have an account”
  • Tap “Revert to default account”

Be aware that it may not showing the account you’re expecting, but we’re mostly looking for where you sub is now :)

1 Like

I tried but that didn’t work too…

Can you do the following then:

  • Tap “Settings”.
  • Tap “About”
  • In the top left corner, you’ll have app version + device info. Tap & hold there for a few short seconds until you’re prompted to send diagnostics. Please do so and let us know when you have.

Okay…I did it sent you log.

1 Like

Thank you!

It looks like you’ve cancelled the auto renewal. That’s what Apple is telling us at least?

Yeah I did, but I paid again and auto-renewal is on right now

You can see it is ON

The info that Apple are giving us isn’t saying this for some reason.

Inside IF, can you go to Settings → About, then press and hold on the text in the top left corner for a few seconds? It’ll ask you to send diagnostics, press Yes and let us know once you’ve done that. Thanks!

Okay I did it again…log sent !!


I noticed you’re using family sharing, are you the family owner?

Yes, I’m the owner.

Okay. It’s weird because the subscription isn’t showing up at all on our end from the data that Apple have given us. Let me look into this a bit more and i’ll get back to you

(also, sorry for making you send two logs! I saw Seb asked you for the log too, I completely missed that)


Hey I completely understand, it’s okay sometimes machines make mistakes too. It’s all okay…I hope you fix the issue soon !! Thank you so much for assisting.

1 Like

Really appreciate your patience. I haven’t seen this issue before.

Just a shot in the dark - can you try going to the Aircraft page, then press “restore purchases”? After that, if you could restart the app, then send diagnostics again, that would help. Thank you :)

Yeah I did that what you said !! Nothing happens though after restoring…

Restart the app now :)

Have you switched Apple ID at any point? Did you create the family account recently? It came up for us under a new receipt, which only happens if the Apple ID is changed. Definitely strange

No I did not do anything !! Didn’t change ID too…