Stuck on loading screen

After installing the new update today, I am stuck in the loading screen. I ran a Speedtest and have excellent connectivity with over 350 download and over 50 upload. Is the IF servers down or is there a bug in the app?

Device:
Operating system:

I am having the same issue

Im no professional but a simple device restart and possibly a clear of cache might do the trick.

1 Like

iPad running iOS 17.4

I have already performed a system restart and cleared my cache

Well sorry mate cant help you any more than i have, not that techy. Best of wishes though

Stuck on the loading screen too. The app worked initially but can’t get it to load since. Tried redownloading and everything.

I have the same problem. But only with the A380

I installed IF on my smartphone and the A380 downloaded without problems. I think its an WLAN Network problem because my WLAN at home is not so fast. Maybe you have to try download the aircraft with an faster Internet Connection!

When you are loading in, what does it say bottom left?

It just says loading with the circle

Have you done a re-install? Seems like a good option to me

After performing an uninstall/reinstall of the app, it started working for me last night.

1 Like

Alright, good that it works again!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.