Stuck on loading screen

Hi, everyone.
I’m stuck on loading screen. I already cleared cache/restarted iPad/reinstalled app/restarted router.
Nothing works so far.

Screenshots attached.
I’m using a 2019 iPad Pro 12.9 inch (3rd generation). Beta ran fine, with no issues.
I can see the servers, so there is some sort of connectivity.

Any assistance would be greatly appreciated.
Thank you.

1 Like

Quick update: I am now receiving an Error Code 7 (see attached).

I did a quick search on the forum, and it seems this is a known issue.
@schyllberg I noticed you managed to solve this issue in the past. Is there any way you can work your magic once again, please? 🙏

Thanks, everyone. Really appreciate your help on this.

Just following on from a prior issue, try removing the app (and from TestFlight) and reinstall from App Store.

Thanks, Sammy. I removed TestFlight all-together, and reinstalled the app from AppStore.
I’m still stuck, though. 😕

Hmm, sorry I couldn’t be of help

1 Like

Are you connected to WiFi? While you may have restarted the router, maybe your device just isn’t connecting.

I have this problem too! it began from 2 or 3 days ago.

Hey, @AlaskaAirfireball111!
I was on WiFi, and it wasn’t working. I restarted my router, and still had the same issue.
I connected my iPad to the iPhone (Personal Hotspot), but no success.

I installed the app on my iPhone and tried connecting from the phone using LTE. Same thing.
Perhaps this is somehow connected to my account? 🤔

The interesting thing is that I can switch between servers, and see all the Airspace activity on the right hand side of the screen. But it won’t connect to the server at all.

Okay, I can’t really diagnose what is wrong here, and eventually, Schyllberg will appear and help out. I wish you the best of luck though!

1 Like

Thank you so much for helping out. Really appreciate the time. 🙏

1 Like

Exactly the same thing for me! I am using VPN now and it resolved! don’t know why i should use it !!


We’re sorry you are having issues connecting to our servers. Please understand that while devices may be the same, the network configuration may be different between users.

Please try the following to resolve your connectivity issue:

Reboot your device

This should always be the first step to resolve any issue. Sometimes the server issue is temporary so waiting a short period of time and/or rebooting may help.

Switch between network types (WIFI/Cellular)

If you are on wifi, try cellular if you can. If you are on cellular, try a wifi connection and see if it is any different.

Try a different network

For troubleshooting, try a different network and see if the results are different.

Toggle airplane mode

– Shut down IF
– Go into airplane mode on your device for 40-60 seconds
– Turn airplane mode off. This causes your device to reconnect to your network and solves the problem for some.

VPN or Proxy

Ensure you are not on a VPN network or behind a proxy. These will often block the necessary UDP ports for a successful connection to the live server.

Reset device network settings


Go to Settings > General > Reset > Reset Network Settings. This also resets Wi-Fi networks and passwords, cellular settings, and VPN and APN settings that you’ve used before.

From the Home screen, navigate: Apps icon Apps icon > Settings > Backup and reset
Tap Reset network settings.
If applicable, enter the PIN, password, fingerprint or pattern then tap RESET SETTINGS again to confirm.

Update wifi DNS settings

In some cases you may need to update your devices DNS settings on wifi to use google’s DNS.

Here’s how to change your iPhone’s DNS servers:

  • From the iPhone’s home screen, tap Settings.
  • Tap Wi-Fi. The available wireless networks in range of your iPhone appear, as shown below.
  • Find your wireless network in the list, and then click the arrow.
  • Tap the DNS field.
  • Delete the current DNS servers, and enter the new DNS servers. (If you enter more than one DNS server, be sure sure to separate the servers with commas.)
  • To use Google DNS, enter and
  • Re-launch IF


  • Open the Settings on the device.
  • Select “Wi-Fi”.
  • Long press your current network, then select “Modify network”.
  • Mark “Show advanced options” check box.
  • Change “IP settings” to “Static”
  • Change DNS1 to
  • Change DNS2 to
  • Press “Save” button, disconnect from the network, and reconnect for changes to take effect.

The DNS can only be changed while on WIFI.

Please make sure you try all the listed steps as described above.

If you have tried all of the steps above, please reply to us with the following information:

  • Your device model
  • Your Infinite Flight version (This can be found in the top left corner after tapping “About” in the app)
  • Connection type, cell/wifi. If cellular, please name the network provider (Verizon, T-Mobile, etc)
  • Country you’re currently in
  • Please list any of the steps above you have already tried and their results.

Thank you!

Most likely an error on your internet service providers side, as a VPN allows you to use different DNS servers among other things than what your service provider offers.

Hey Mate,

close all your apps from the iPad Pro, and then switch off your iPad completely, then wait about 3 minutes and then switch it back ON, IF should then work again.

it always worked for me.

Best Regrads Vinny

Thank you so much, @schyllberg 🙏.

Reseting the network settings and updating the DNS solved the issue. The loading time is now close to 30 seconds, but it works.

I appreciate the time you took to respond. Many thanks.
At your convenience, please close this topic.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.