Stuck in loading Screen

Hello Team, I was flying till now, I landed to re spawn in a new aircraft, the IF froze at loading screen, I tried force closing it and opening again. Now it’s frozen at the infinite logo page. My Internet connection is good.


Here is the screen recording link https://drive.google.com/file/d/10QUo0AHal-VxeO8ttTOryQ9mQTqec0Pb/view?usp=drivesdk

What might be wrong here ?
I tried restarting the device as well.

Device : iPad Pro
iOS 14

1 Like

Hi there!

I’d suggest deleting and reinstalling the app. This won’t affect your account or subscription, however will permanently remove cached data (such as aircraft liveries and terrain), along with your replays.

Let me know if this helps!

1 Like

I tried uninstalling the app and reinstalling it mate, it’s still stuck the same screen @Ecoops123

1 Like

How much storage do you have left? I ran into this problem and it was due to my storage.

1 Like

He has 38 GB left in his device

1 Like

I have have ample of storage space.

1 Like

Hi, just to rule out your provider doing shenanigans between you and IF servers, try changing DNS by following the steps from this tutorial, but instead, enter the following DNS addresses:
8.8.8.8
8.8.4.4
It’s advised you do it in the right order, and even if it won’t help your internet will become a bit faster because of speedier google servers

Thank you it, I have updated it. But As for IF the same issue persists.

Are you on Wifi or cellular? You can try the other if possible. If able try a different network if you are on Wifi. Friends house, etc.

Are you using a VPN by chance?

It sounds like it is a connection issue with your network so we are going to try to see if it works on others to narrow down the problem.

If all else fails you can try resetting your network connections. You will need to make sure you have your network credentials handy to reconnect. Tap Settings > General > Reset > Reset Network Settings. This also resets Wi-Fi networks and passwords, cellular settings, and VPN and APN settings that you’ve used before.

I would just turn off and on my wifi.

I am in my home Wifi, my iPad Pro does not have cellular.
I have tired switching it with multiple network. One would be my phones hotspot (different network and another will be a different Wifi router) Still it’s froze in the IF screen.

No, I am not using VPN.

I tried rebooting my router, and resetting the network connections in my iPad as well as the router, still no luck.

1 Like

@Chris_S

It logged in successfully now, after updating the navigational database but it’s stuck at this screen now.

There could be an issue with a particular CDN provider for your area which may be resulting in that. It could resolve on its own as you’ve tried reboots, reinstalled, and switching hotspots.

I see it is making slow progress so I would let it work and see if it comes back even if it is slowly.

Roger @Chris_S kindly keep this thread open, I will be reporting back once IF starts working.
It’s still stuck at the same loading screen shall I force close the IF and try opening IF again? Or wait.

1 Like

I would wait a little longer. Then turn off your device, wait 2 minutes, and then turn it back on and log into IF again.

Thank you @Chris_S and everyone my IF is back online again, 100 more landings I will be at grade 5 for the first time.
Cheers ✌️🚀
This thread can be closed.

4 Likes