Stuck at Contacting Server

I was about to do a short haul from KMEM-KOAK but I was not able to since I’ve been logged out. Now when I tried to relog, it has been saying “Contacting Server” for the past 20-30 mins. Any idea what happened?

Try powering down your device and restarting.

Already did that. Same thing.

If you are on WiFi go ahead and reset your router.

It’s likely a connection issue on your end.

Ill try switch to data and see if that works. While doing that, Ill reset my router.

1 Like

Make sure you have a strong WiFi signal too because that will impede your progress.

Im using my data and it is still saying “Contacting Server”. I dont think its my connection issue because I even tried opening like 5 websites on my data and all of it opened within seconds.


Can you go into your device settings and reset your network settings for us. Once you complete that close Infinite Flight, reboot your device and relaunch Infinite Flight.

Apple Devices-


  • Go to Settings.
  • Go to Backup & reset.
  • Now tap on the “Network settings reset” option.
  • Hit the “Reset Settings” button.
  • You will be given another warning, hit the “Reset Settings” button again.

Done. Still says Contacting Server.

Should I try reinstalling IF?

You can try that yes.

2 mins. Still saying the same thing. Is there like a shard down for the Server or something?

There’s a lot of activity on all of the servers right now. I’m flying on the Expert Server right now. I’m trying to go through everything that has worked in the past to assist you. How is your connection and what are the speeds? Is this the first time you’ve encountered this?

Can you try this after closing the app and relaunching it:

  • Relaunch Infinite Flight (make sure you stop it from running in the background first)
  • Before starting a new flight, Go to Settings —> General —> Tap “Clear scenery cache”. It’s in the bottom.
  • Start a flight (try on Solo first)

My Download Speed is 55.18mbps and my upload speed is 40.14mbps. Yes, this is the first time I’ve encountered this issue.

1 Like

See our new response above ;)

Yep I can fly in Solo. No issues.

Did you try clearing cache a few times (make sure you tap on yes when prompted, I know that the orange No seems enticing)?

Yep. I pressed “Yes”. I did it before and after the solo

Okay, do me a favor so that we start fresh. Fully power down your device, relaunch IF once it powers back up, change your airport to KPHX and change your aircraft to the Cessna 172 and try spawning in on the Casual Server.