Struggling to get ATC voice

Hi all!

My brand new phone (already in-flight), my Samsung Galaxy A70, is having trouble running an ATC voice. I’ve looked into the support FAQ and tried the suggestions given with no success. Any suggestions from any Android users or supporters?


‘No Voices Found’, I’ve tried downloading multiple English files, and so far none have shown :)


I’m not too concerned currently, I’m about 3 hours away from Abu Dhabi and think it would be helpful to hear what’s going on.

1 Like

If I’m understanding the issue right, go to the Google Play store and download the Google text to speech. Then go to your text-to-speech settings on your device and set the Google TTS as your default. Or you could use Samsung’s and set that in your device TTS settings but they don’t have as many voices.

1 Like

I hoped this would solve the issue simply but these were the first 2 options I had tried. Following both the success wasn’t in sight… or in flight.

This may be something you cant change mid-flight unfortunately.

What TTS engine does your device show? Have you installed google tts and rebooted?

1 Like

My device shows the 2 standard Googoe and Samsubg default voices. I’ve downloaded a selection on languages off there. I’ll test it again, now with the app restarted.

The results are back. All downloads were successful and have now got a massive selection of voices to choose from. I think my device didn’t yet have the downloaded texts. (It was literally not even 5 minutes fresh out the box after the flight was started).

1 Like