still having connection issues

I made a topic about this a couple days ago and have tried everything. I deleted and redownloaded the app restart my device and done everything in my power. The problem is that I somehow everytime I fly a medium too long haul route at some point lose connection to the live server. Everything else works fine Global Server and User account are good. I’ll use the flight I’m currently conducting as an example. I’m flying from WSSS-KEWR in the 787-10. I took of with working Unicom and multiple planes around me I flew for a couple hours and at somepoint I can’t currently pinpoint the Live server disconnected. My wifi connection is stable and works on both of my other devices, I also tried connecting to my phones hotspot wich also didn’t cause IF to reconnect to the live server. I don’t know what to do please help. Also I’m using a flightstick that works and can connect to IF. Also when you press on the red live server exclamation mark it says Disconnected: NetworkError. @Levet helped me out last time.

And if you click on the little red exclamation mark in the top right it shows “Disconnected?”

yes that is the problem

Do you stay in the app the whole time?

yes of course

1 Like

I just completed my flight from singapore to newark, I have a screenshot of my completed fpl for a 17h flight but when I ended flight it said 1h and in my logbook it also only says 1h so this glitch is also ruining my stats.

If you send this to the mods they might be able to do better than the community 😉

@schyllberg (support)

Hi Luca,

I see that you weren’t able to reconnect. Can you answer a few questions for us so that we can troubleshoot your issue:

  • Did this occur on the Training Server?
  • Is your internet connection via WiFi or Cellular?
  • Has this issue just started recently (the last few days)?
  • How strong is your service signal (either WiFi or Cellular)?
  • Once you launch Infinite Flight do you leave the app at all and at any time?

We’ll look for your response to see how to move forward. Sorry for the inconvenience, Levet

1 Like

I did this flight on casual since I wasnt sure of the 787s range, my internet connection is via wifi,
about two-three days after consistently doing long hauls using IF on a new IPad, 42mbps down 4.3mbps up, I do not leave the app during my flight I did after the connection issue occured to try and restart my wifi aswell as try and reconnect by switching from wifi to a cellular hotspot to wifi.


Do you know what kind of internet service provider you have that you are connected to through wifi? There are internet types that are a bit of a “burst” internet, especially in rural areas that would cause this issue.

What kind of phone are you using? if iPhone, do you have use network settings turned on to connect when wifi isnt strong enough? (which actually causes a problem with connection)

1 Like

Swisscom for wifi its one of the top service providers in switzerland and as stated above I’m using an IPad without a cellular connection

@Luca_bad_joke thank you for updating us. I will have a chat with fellow mods and staff.

Have you conducted any flights since this incident and if so has your connection to the Global Servers returned to a connected status?

I haven’t yet this was the third or fourth flight this happened

Okay, keep us updated if you spawn in again and see this issue. Sincerely, Levet

I also have had this issue for the last 4 weeks and haven’t found any way to fix it really getting frustrating every server it happen on, I deleted and reinstall, Lowed settings and quality as well as cleared 50 g b of storage and still not Better. It is not just me then.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.