Starting at a lower than usual speed when using “Short final” button on solo

Good morning/afternoon/evening

I’ve just started the app for the first time after downloading 21.3 and spawned at a new 3D airport with an A350 to have a look and train some landings.

After I adjusted my load and weather, I paused and used the “Short final” button, just to see that the starting speed, which should around 140-145 knots, was actually about 125 knots.

I then tried it with more commercial aircraft (772, A320, 739 and a few more) and it happened to all of them. Non-commercial aircraft had their normal speed tho.

Solutions tried
  • App restart
  • Device restart
  • Changing the airport

Is this a bug or is it intentional? I’d really like to know


The same thing happens to me. I think that’s how it’s supposed to be, but I’m not sure why…lol.


Hi there,I’ve had the same issue and was wondering about the same!


I hope that changes tho
Don’t want to go 100% power every single time I use the “short final” button just not to touch the ground before the runway


Yeah, same. I always have to firewall the throttle to land correctly lol.


This I believe is intentional.


I haven’t tried this for some time, but I believe the app spawns you at a fixed groundspeed. If you wish to increase your IAS, make it such that you experience headwinds upon spawning.

I don’t believe this is really an issue. Since I’ve been messing around with it, I notice the speed is actually around 130 IAS (145-150 for 747s and A388) and drops rapidly. Therefore the solution would be a lower load, and increase thrust. Similar IRL, thrust is never set to idle until the pilots starts the flare of an aircraft and the weight would be somewhere below the MLW.

I find that your power setting should be somewhere between 30-40% to maintain your speed on final. Hope this helps!

It spawns me on 120knts, I then stall and crash.

1 Like

It might be in your winds or temperature. Try messing with those when you spawn in. I believe a higher temperature results in a lower airspeed. I might be wrong, but try it out.


it always starts at 125 no matter the load and temperature and if I don’t set full power immediately I end up crashing before the runway

not this since I’ve tried airports with different altitudes and the airspeed is always 125, even if the ground speed is different

1 Like

Same! I don’t why it’s happening,I have to give full power as soon as I spawn!

Thanks for letting us know about this. We made some adjustments to this system in 21.3 but it looks like it still needs some fine tuning, which we’ll look at for 21.4

1 Like

thanks a lot Cam

Great to know its not totally intentional


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.