Sound cutting out

Hello, I’ve had a problem where the sound cuts out including the unicom sound. The unicom sound does eventually come back but the aircraft sound is cut out completely. I checked the audio settings in the app and everything was on full and my device sound was working perfectly as well. I saw someone had the same issue but that was almost two years ago so I just wanted to post again.

I am using a Google Pixel C and I was flying from Heathrow to Miami in the newly released 777-200 using the British Airways Livery. I am wondering if this is a bug or a problem with my device because it is 3 years old and the software updates have stopped for my device.

I would appreciate your thoughts on this

Thank you

Hi Josh! Usually the ATC audio part of this cuts out after a call has been made during the flight but in some cases it just happens I think. A way that people are solving this side of the issue is by going into the in game settings where you have the ATC voices and clicking another voice and going back to your original voice. I’d try doing this to get your ATC audio back. Hope I helped! :)


Ok thank you, I was just annoyed when I couldn’t properly hear the engine sound on approach, I just love the new engine sounds and yes I shall try what you mentioned :-)

And yes it’s the engine sound that cuts out completely, the ATC sound does come back. Even when a call is being made, sometimes there is no sound at all.

I’m also experiencing sound cutting out but mine does not come back even after playing with the settings. Aircraft sounds and ATC both not working after around 1hr into flight. I’m using a new ipad air and all my settings are OK on that. Do not disturb etc all turned off. Is it possibly an issue with IF and low power mode? I have only experienced this since the last hotfix update on apple.

This exact same thing has happened to me too, and it started fairly recently (about the same time as the 20.1 release). It has never happened to me before and it has happened at least 3-4 times in the past two weeks. It happens with long hauls and short hauls but I still haven’t figured out what the issue is.

P.S. it doesn’t happen to me all time but sometimes.

I tried turning off the low power mode for long flights option in the settings and it seems to have done the trick, hopefully this helps you out!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.