Some Terrain and Airports Not Loading Properly

This never happens immediatly when I spawn in, but when I fly a decent distance the terrain stops loading in properly, then when I actually arrive at the airport it doesn’t load properly or doesn’t load at all. The other day I was flying to Memphis and when I got on final the airport just wasn’t there, heres some pictures of my flight to Sydney yesterday when the glitch happened.

Here you can see the divide in where the terrain becomes bad looking.

Just to show where I am on the map

When I arrived in Sydney it looked like this (Taxiways not loading properly)


I’ve tried uninstalling already and that didn’t help, if anyone knows the solution to this I would be very happy to know because it really annoys me during longer flights.

2 Likes

Have you ensured that you have a stable internet connection and that you have restarted your device?

Judging by the fact you have a yellow ! in the top right, it looks like your connection isn’t perfect.
I suggest you try restarting your router or moving to a different network. This should do the trick :)

Where exactly are you flying because you might be in a low resolution part of the world?

He is flying in Aussieland by the looks of the ATC comm bar. That has 15M scenery.

1 Like

I restarted my device a few times already, also this has happened different WiFi networks.

I’m aware of that, but I was in Australia which has the high resolution scenery, plus this has happened in the United States and in Canada as well.

How’s the overall internet connectivity on Cayman Islands?

Reason i’m asking, is because the terrain is streamed via something called a CDN (content delivery network)…
That requires the CDN first to download the scenery from the FDS Servers, and then redistribute them around the world.

What do you get if you try Speedtest?

I’ll attempt to restart my router, but this has happened on 3 different networks, so I’m not sure if it’s the router or maybe my device.

Overall the internet connection is good here, but mine specifically is not the best (Can’t afford high speed internet because it’s expensive here)

This is what I got on the speed test:
52 PM

Thanks!
It’s not the best, but it should be sufficient.
Not 100% sure why it would help, but as you’ve tried different networks and so on and are still experiencing this… i’d recommend a reinstall of the app to see if it improves.

1 Like

No that’s enough. As long as it’s above 3mbps it should be alright for streaming

1 Like

I’ve already reinstalled the app and I’ve tried it on my friend’s internet (He gets about 25Mbps download) and it still happened. I will try to reinstall the app again to see if it will fix it though.

It appears to have fixed after reinstalling the app for the second time, thanks for the help, I really appreciate it.

1 Like