Simulator shuts down mid flight

Hi I have tried flying from jfk to Heathrow three times and the app closes suddenly each time when I’m about 10 minutes into the flight. Always at about 30000ft in 747. Is there anything I am doing wrong or is it just overloaded? There are always a few aircraft on server but I’m not near the airport. Any advice appreciated.

Hi, if you are using an Apple device update your iOS to 11.4 :)


This happened to me when I was on Android! Even happened when I was on short haul flights too, I suggest lowering your graphics and everything else down, close all apps, restart the device and even clear the scenery cache! You can even try deleting and reinstalling the app

What device are you using?
What software are you running on?
Is your device overheating overtime?

Always restart your device before you go on IF no matter what your device it always helps I’ve been able to do ultra long hauls which I probably wouldn’t have been able to do otherwise

This has happened to me previously on the S8+ I would recommend making sure all background apps are closed and try lowering your graphic settings within the app. Also ensure anti aliasing is enabled. Hope this helps.

First of all you have to mention your device model and wether u have updated the latest software ?
Eg: for Android latest one is Oreo…

For those who are having trouble with their device please refer to this thread.

1 Like

For android latest one is P 😜

1 Like

Thanks for all your comments, I tried closing all background apps and still the same problem. It definitely seems like something in the background u randomly turning it off. When it crashes out I seem to have lost my wifi connection so maybe that is something to do with it. I will try a restart and see what happens. I have a moto g 3rd edition and software is fully updated. Thanks and I’ll let you know if I fix it.


U got me bro … Thnx for correcting me.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.