Scenic

So I’m trying to screenshot and well when I go to scenic or something of that sort my HUD won’t disappear so I can take a legitimate screenshot.

Hi there,

You can change the Interface timer settings. Go into Settings > General > Select an entry

You should also select the “Hide Status Bar” option so that the bar will also disappear.

Many of the setting can solve what you are looking for.