Scenery not loading, lag and app crashing.

Ok, getting a little frustrated with IF lately.

I run IF on my iPad pro and have fibre optic broadband. I really enjoy it, but in the last few weeks I’ve started to have issues that I’ve never had before! Here is a few flights I’ve operated and the issues I’ve had:

I flew the A321 from Madrid to Alicante, Spain. On descent and approach the scenery didn’t load properly and the airport wasn’t actually there.

I flew the MD11F from Riyadh to Zaragoza, Spain. Everything was fine until I approached Barcelona and the scenery wasn’t loading properly. I then commenced my descent into Zaragoza, the lag slowly increased until it became unbearable and the scenery directly below the aircraft disappeared entirely. See picture.IMG_0466

Then I operated the A330F from Zaragoza to Aguadilla, PR. This flight went completely fine.

I then decided to reinstall IF to see if things would be any better. Things were better for the first few flights until now.

I’ve just flew a flight overnight from LGW to LAX on the B789. Spent a lot of time planning the flight to avoid the strong Polar Front Jetstream currently over the Atlantic. Everything was absolutely fine the whole way, descent started fine. Until, I was about 60nm out from LAX and the lag started, then the app crashed completely. I know LAX is usually quite busy on IF, but there was only about 6 or 7 a/c online whilst I was in the approach.

So, does anybody have any ideas what is actually happening? I really enjoy IF, but if its going to continue like this I will stop using it.

1 Like

I guess you’re having the black floor glitch. It happens on some flights and is a known issue. I guess we’ll have to wait for FDS to fix this glitch. It has a lower chance of occurring by lowering the graphics. Lowering the graphics also reduces the chances of the app crashing.

1 Like

Are you sure you have a strong internet connection? Those likely only happened when internet not good enough. Even if you use fiber optic internet doesn’t always mean it’s good enough for IF :) or your provider might have connections issue there.

Also, What camera view did you use during approaching the airport? I usually having lags if I use bad internet connection in cockpit1 or cockpit 2 view. If you also use cockpit camera view, I suggest turn off the mini map.

By the description he said, probably he experienced this :

If so, then as i said, bad internet connection :)

This has happened to me a few times. The one thing that usually worked it exiting out of the WiFi and going to LTE until you land. The other reasons might be if you paused the game too much it can disrupt the connection, had that happen too.

Thanks for the replies everyone. I edited my post, so I hope the image is loading fine for everyone.

My internet is usually around 56mbps.

Also, yes I always fly in cockpit when doing the approach, so I’ll take your advise and switch the mini map off next time.

ekolaziale’s image is exactly what I experienced on app to ALC, so ok, must have been a glitch in the internet!

I get a lot of fb messenger calls on my iPad and usually have to exit IF to answer, but i received no calls at all on the LGW-LAX flight, so I can’t say the flight was interrupted last night.

How come I have never experienced this bug? Running an Air 2…

@Boeing773ER the black floor glitch occurs very randomly, but a certain way to get it is to fly for a very long time.
I’ve also experienced the black floor glitch a couple of times on long hauls, on routes such as EGLL-VIDP, with the flight time under 10 hours.
I guess we’ll have to wait for FDS this glitch.
Meanwhile, we can lower the chances of it occurring by lowering the graphics.

Sorry to say, but that theory doesn’t hold up. The black floor thing can happen on any graphic setting. Quite the opposite to what you believe, it is caused by some sort of connection glitch. It probably have nothing to do with the speed of your connection, but some sort of connectivity issue is the cause. And then the app fails to stream the terrain again for unknown reason once the glitch has passed.

The reason you’re not noticing any change when going from low to medium or vice versa, is because the imagery is the same for those two.

As i said ;) The app won’t try to redownload imagery it already thinks it has.

1 Like

Absolutely. It can be a fix sometimes when you run into the issue.

It’s being looked at, but not an easy bug to reproduce i’m afraid.

1 Like