Scenery loading in error

Hi, I just completed a flight to London Heathrow, but when I landed at EGLL the airport taxiways and buildings were not there. I had to leave and re land the plane in solo mode, thankfully. However, when I checked the replay file everything was fine and the airport was loaded in. Im not sure why this is and I wanted to get some clarity on this issue and if I could have prevented it somehow?

Device: Ipad Gen 8

1 Like

Hey! Try clearing your scenery cache in settings to see if this helps. Usually this happens to me when I’m running out of storage and clearing my cache fixes the problem.

I did not work the first time but i tried in the replay mode and it worked. Thanks.

1 Like

Another thing you can do is clear storage on your device. Usually, scenery has trouble loading when there isn’t enough temporary storage on the device, hence why clearing the cache is good, but I’d also look into uninstalling unnecessary apps and such.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.