Scenery Glitch


I’m on approach into Newark from San Fransisco, and now the scenery looks like the ocean (I’m above Pennsylvania).
Now all the airports are beneath the ground, and if I try to land, I will clip through the ground, not be able to see anything, and crash. This isn’t the first time, it happened to me in Denver a couple months ago, too. This is a really frustrating glitch, because I lose long flights which I took hours from my weekend to fly. Is there any way I can fix this?

Hi, use the clear cache feature in your in app settings.

  • Be sure you have a stable internet connection.

  • Reset your router occasionally

  • Keep as much device storage and RAM available as you can

4 Likes

I tried that, it has no affect.
And also, it turns out that I’m not connected on live. My internet is great, Infinite Flight has the green check mark next to everything, but nobody can see me on radar or anything. (UVA-035 is my callsign, on Expert Server)

Try switching your device to airplane mode for 30 seconds then see if you reconnect to the servers.

1 Like

Even when my device was on Airplane Mode, the Server Status still showed me (falsely) connected to everything…

Try resetting your WiFi and see what happens.

At this point it may be better to end your flight aswell in case it’s an isolated issue perhaps. Restart the app aswell.

1 Like

If you encounter this you don’t lose your flight hours as that is stored and refreshed to the server regularly.

alright, I’ve ended the flight and restarded the app.

ik but I didn’t get the landing, and I can’t log the flight for my VA, but that’s alright lol, I can just redo the flight on monday

When you encounter this the best thing to do is try the clear cache feature, if that doesn’t work go to airplane mode and reset your router before you quit a long flight again. I’d rather try everything I can rather than quit and not be able to log my flight.

2 Likes

May i add one thing?
This has happened to me before as well. Last time was 2 months ago and that’s the only time it has ever happened to me. So it’s not a completely isolated scenario but i can be narrowed diwn to us two only.
And obviously back then we didn’t have the “Clear Cache” feature, so i don’t know whether it would work if i tried but all i know is that my internet at some point got cut off for a few minutes and after that this “glitch” occured. Since then i’ve had no problem with my internet and therefore no such issues.
That’s my side of the story at least.

1 Like