Scenery display error

After an 11 hour flight from Wellington to Guangzhou, on approach to destination the screen flashes erratically and there is no airport to land. No lights, no apron and no surrounding scenery. iPad Air 2 running iOS 11.2.

Hey there!

That’s from corrupt files.

It should be fixed the next time that you fly

Tips Before Flying Love Hauls:

  • Before long hauls please conduct a full restart of your device.
  • Make sure you have plenty of RAM available (1GB minimum) on your device.
  • Refrain from backing in and out of the app.

Leaving Infinite Flight during flying operations causes issues. As Terrain is streamed and this requires a stable internet connection.


Haha best typo ever xD


Infinite flight is stuck at the loading screen after a long while now.

I experienced this morning too after long flight
IPad2017 iOS11.3beta
Was lagging and some part is black floor, so I end the flight.

It’s hard to avoid even if u have high performance on ur device.
IF game requires a lot ram and stuff.

Please try the following to resolve your connectivity issue where you are stuck on the loading screen. This means you are not able to reach the servers:

Reboot your device

This should always be the first step to resolve any issue. Sometimes the server issue is temporary so waiting a short period of time and/or rebooting may help.

Switch between network types (WIFI/Cellular)

If you are on wifi, try cellular if you can. If you are on cellular, try a wifi connection and see if it is any different.

Try a different network

For troubleshooting, try a different network and see if the results are different.

Toggle airplane mode

– Shut down IF
– Go into airplane mode on your device for 40-60 seconds
– Turn airplane mode off. This causes your device to reconnect to your network and solves the problem for some.

VPN or Proxy

Ensure you are not on a VPN network or behind a proxy. These will often block the necessary UDP ports for a successful connection to the live server.

Reset device network settings


Go to Settings > General > Reset > Reset Network Settings. This also resets Wi-Fi networks and passwords, cellular settings, and VPN and APN settings that you’ve used before.

From the Home screen, navigate: Apps icon Apps icon > Settings > Backup and reset
Tap Reset network settings.
If applicable, enter the PIN, password, fingerprint or pattern then tap RESET SETTINGS again to confirm.

Update wifi DNS settings

In some cases you may need to update your devices DNS settings on wifi to use google’s DNS.

Here’s how to change your iPhone’s DNS servers:

  • From the iPhone’s home screen, tap Settings.
  • Tap Wi-Fi. The available wireless networks in range of your iPhone appear, as shown below.
  • Find your wireless network in the list, and then click the arrow.
  • Tap the DNS field.
  • Delete the current DNS servers, and enter the new DNS servers. (If you enter more than one DNS server, be sure sure to separate the servers with commas.)
  • To use Google DNS, enter and
  • Re-launch IF


  • Open the Settings on the device.
  • Select “Wi-Fi”.
  • Long press your current network, then select “Modify network”.
  • Mark “Show advanced options” check box.
  • Change “IP settings” to “Static”
  • Change DNS1 to
  • Change DNS2 to
  • Press “Save” button, disconnect from the network, and reconnect for changes to take effect.

The DNS can only be changed while on WIFI.

When replying please help us out by ensuring you provide ALL of the following:

  • Your device model
  • Your infinite flight version
  • Connection type, cell/wifi. If cellular, please provide the network name (Verizon, T-Mobile, etc)
  • Country
  • Please list any of the steps above you have already tried and their results.

Thank you!

I have tried rebooting and I’m sure it isn’t a network issue because I’m typing on the same iPad. Funny enough ATC works alright but when I try to fly solo or online, it gets stuck at the loading screen.

You cannot compare the two and assume it is not a network issue. The loading screen uses different network protocols.

Are you behind a VPN?
Can you try resetting your network settings as this has helped people in the past.

I have reset the network several times, tried a different WiFi connection and no I’m not using a VPN

Can you try changing your DNS?

What country are you in?

I’m in Ghana. I have flushed DNS a few times

Not flush, change the dns to use google. and on your device.

I will try that and see

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.