Satellite airports

I was landing after a 6 hour flight today in CYYC and the runways and taxiways didn’t show up, just the IF satellite imagery of the airport. I performed a go around to let the airport load but it didn’t so I had to very closely follow the taxi map to get to my gate.


Ignore that I have 660 hours and am still landing with the hud view

2 Likes

Clear your scenery cache.

I have 4,140 hours and I land with cockpit HUD view. It’s just a game, don’t worry about what people think about this.

4 Likes

Aight. I’ll clear it but I’ve never had this issue before.

Hey mate,

This has been a known issue very recently as you can see from the topic that I’ve linked below for you:



The Infinite Flight team have released a hotfix for both Android and iOS, so just confirming you have double checked that you have the latest version of Infinite Flight downloaded to your device?

If you have, I recommend checking out Cameron’s reply that I’ve quoted below for you, taken from the topic above:


Let us know if any of this works!

2 Likes

Ya I have the hot fix downloaded

Okay, and I’m assuming you’ve tried what Cameron mentioned in his reply above in regards to clearing your scenery cache from the main menu (not in game) and then restarting the app?

1 Like

Yes I just did that 5 min ago

After you did that, have you experienced the issue again?

1 Like

I just checked and the airports are loading in. Thx for the help guys

No worries, glad we were able to help you out!

Don’t hesitate to create a support topic again if you experience this issue in the future. Fingers crossed you don’t though!

1 Like

Thanks. I’ll contact if I experience issues again. IF doesn’t have too many bugs tho.

1 Like

Sure I always land with the hud to with over 2500 flight hours landings are so much smoother with the hud on 😌

Clear scenery cache usually works happened me coming in to land at Geneva before

1 Like

Wait you’re not supposed to land with HUD? xD I kid, I kid, of course

Glad you got the issue worked out!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.