Saitek yoke not detected

I just got a new yoke and throtle quadrant. it is a saitek toke. it is detected but when i get into game it stops working does any one have a fix.

Are you using an Android or an IOS device?

I believe the yoke isn’t supported. But, I could be wrong.

EDIT: Wait, no it is. I remember trying it once.

i am using an android s8

Depends on which Saitek it is. The X52 Pro is supported.

I had one. I showed it in a setup tour. Anyway, are you using IF Connect to do it or the direct thing with Android?


Right, but the X52 is a joystick, not a yoke.

1 Like

its not an x52 its the pro flight yoke and yes im using the direct method to plug it in

Ok I have the same on for FS9/FSX. I think it works, but not 100% sure.

@Swiss isn’t that what you used?

I think a phone cant stand that voltage. Use IF Connect with a computer. By the way I sent my yoke and thottle back.

1 Like

it works and then ill turn my engines on or something and it randomly stops working

1 Like

Try using a PC with LiveFlight Connect and see if that works. The yoke and throttle might be using too much power from your phone’s USB.

can you see this message? (i think i am banned from here already lol)

1 Like

Yes. I copy you. Loud and clear xD

Roger dodger. Thanks.

1 Like

ok and how do i set the yoke up on pc i tried like 15 min ago didnt work so i came here

Do you have windows or mac?

1 Like

Follow the tutorials on here if you haven’t.

1 Like

windows 10 it worked on my old pc with windows 7 but thet was with a different yoke

I run my joystick with Windows 10. Just take a look at the link and that should help you.