Rudder Pedals Not Working with IF (LiveFlight)

Hello Community,
A few weeks ago, I purchased a Logitech yoke to use with Infinite Flight through LiveFlight. They worked flawlessly, so I decided to also buy Logitech rudder pedals to control the rudder more easily.
However, some issues have arisen:

  • When my rudder pedals are connected, IF half the time refuses to recognize input from both my yoke and pedals. The “you are connected!” screen on LiveFlight appears, but going into the Controls section of IF’s settings, the devices do not respond. (This does not occur when only my yoke is plugged in - with only the yoke, LiveFlight connects successfully on the first try 90% of the time.)
  • Secondly, when the connection is successful, something strange happens: IF completely ignores the yoke and throttle quadrant. It only accepts inputs from the pedals, automatically setting one toe brake as pitch control and the other as roll control. (but at least Yaw works…)

All drivers and software are current. I’ve even tested both on X-Plane 11, and they seem to work just fine.

I’ve also looked at this topic:


but no solution was given.

Is anyone able to provide any help or advice?




Edit 7/15/19:

2 Likes

Is there anyone on IFC who uses a yoke and rudder pedals with Infinite Flight? I’m sure there are Community members who can offer at least some assistance.

Indeed I do, I use A Yoke; throttle quadrant, and a joystick, I also have rudder pedals

1 Like

The issue is that IFconnect and IF isn’t compatible with rudder pedals, as it doesn’t have the axes in its system, but there is a way to make rubbers work. But you’ve gotta sacrifice your throttle. If you connect the Rudder to the THROTTLE and spawn into a flight, when you move the rubber, the rudder will move, but you will no longer have anything but your hand to move the throttle on the screen

I never use rudder peddles with IF, I use my joysticks axes, when you move your wrist left and right as the rudder, even with Boeing, I fly realistically, and with Boeing I was my Yoke, and Airbus, I use my joystick. Either way my joysticks rudder axes to move the rudder

So do you think that even if I unplug the throttle, the yoke will still work?

It should, since I have a throttle quadrant(connected to my yoke), and my gear and flaps are set with that I don’t unplug it, I just delete the axes with IF. Then I hit set and move the rudder, then the pedals should work

For some reason, mine seems to act up, since when everything is connected (yoke, throttle quadrant, pedals), IF completely stops recognizing the axes from the throttle and yoke and instead takes all three axis from the pedals (1. rudder, 2. left toe brake, 3. right toe brake). But I’ll try it later today without the throttle quadrant plugged in and see what happens.

I also have a joystick, but I haven’t seen what the pedals do when the joystick is plugged in.

@Blake_Stephens If you don’t mind - which company/model yoke, throttle, & pedals are you using?

Try getting rid of the rudder pedals first, everything should work if you get rid of those. Even my rudder pedals don’t work right. I am currently on Vacation, and I will send you a DM when I’m back…won’t be for a few hours. Sorry.

1 Like

Yes, the yoke & throttle work with IF when I don’t use pedals. I was just hoping I’d be able to avoid moving the on-screen slider every time I move the rudder.

No problem! I really appreciate your help. Enjoy your trip! :)

1 Like

Yes, sadly there is no way at this current time to have everything work how they should, but you can use your joystick as a rudder, which is what I use!

1 Like

Ok, try plugging your rudder petals into your yoke and plugging in to the computer. Just hook up the pedals to the side of the yoke in one of the 3 USB ports

I’m thinking of getting all this so this is a important topic for me

1 Like

I have tried plugging the pedals into the PC’s USB ports and into the yoke’s USB ports, but unfortunately, neither method seemed to work.

Have you restarted both machines?

And then go into settings and reset all your stuff.

Hey, did it work?

Sorry, I had to leave for a bit.
I’ve tried restarting and whatnot, but the problem seems to be about the number of axis IF can register. It’ll accept 3 - roll, pitch, throttle - but not the rudder pedals.

There is a use option, press it and then move the rudder petals

I’ve tried this, doesn’t work unfortunately…