Rudder Pedals not detected

Hello, I got the Logitech rudder petals along with the yoke and throttle for Christmas and the rudder isn’t detected. Is there anyway to fix it.

Im using liveflight connect

Hey @BadPlane

I also got the same thing. I haven’t tried setting up the rudders yet (apparently they are a hassle.) Were you able to get the yoke working properly. It’s acting kind of strange for me.

1 Like

Yes I was. It wasn’t a problem

Im going to get started on the rudder petals soon and let you know what happens. I just want to know if you were able to get reverse thrust to work on the thrust levers…if so how did you do it

1 Like

I have em and they can be a hassle. Does your yoke have a USB port in it? It helps to plug the pedals into the yoke and not directly into the computer.

3 Likes

I tried and it didn’t detect them

Ok. Are you using LiveFlight Connect? Or are you connecting them straight to your device?

1 Like

@BadPlane I just tried connecting mine and mine seem to be working. Did you set yours up yet?

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.