Rudder not working

Has anyone experienced this issue?It seems that upon landing I tried to use rudder to maintain the centerline but I dont get any response from it. I slided it all the way to left-right and I almost get no response to the input.

1 Like

Highspeeds the rudder doesn’t work as well. Push the nose down and slow down and you get better control. Wind is another small factor and can overcome the rudder control.

Do not restart or re-install, do not recalibrate as the Rudder is controlled by your finger not your device this does happen

Hi Gabriel!
Have you tried calibrating your device?

It is harder to move at higher speeds. Once you get to a lower speed at around 80 knots it will work fine. This encourages us to use rudder more in the air I found out. It also creates more realism.

In the latest update, the rudder was made more stiff for realism and controllibilty in crosswinds. Try lining up with the center of the runway a bit before you are final.

Oh I see. That makes sense

I understand that but it kinda makes it a little hard to maintain centerline after landing.

Not an issue. Use rudder to get the aircraft tracking straight down the center of the runway prior to main gear touchdown and nose wheel touch down. Its not hard to maintain centerline if you have the aircraft tracking straight before the touchdown. In fact, its easier to maintain centerline if winds are present. Practice, practice, practice!