Rudder and reverse thrust Problem !

Hello, I may have a bug. When I land with a crosswind, I have to use both rudder and reverse thrust at the same time, but when I press both at the same time, it bugs and both don’t go off, they become unusable. I tested it:

  • clear the cache. (Does not work)
  • re-installation. (Does not work)

My device is a Google Pixel C under Android 7.1.2 !

Thank you in advance!

Is this a new bug/ Have you any experience with crosswind landings?

(Just to make sure whether this is an app issue, no offence).

Sometimes rudder does not work at a high speed, try tilting your device like you would in the air, and then start rudder and lower speeds.

Just to clarify; what you mean is, when you apply reverse thrust and rudder separately, they work ok, but when you apply both, then there is no rudder working and also no reverse thrust (they both don’t work)?

Have you tried this with multiple aircrafts?

1 Like

Also remember to keep rudder movements to a minimum, as your plane might spin out.

That’s not his problem, his problem is that they can’t be used at the same time

@azeeuwnl Yes that’s right, when I press the rudder individually and the thrust reverser everything works. But when I press both at the same time, the buttons don’t activate.

That shouldn’t really be a problem then because you don’t press them both at the same time when you’re landing

@Marc.Stinger - can you enable “Show touches” (General tab) in the Infinite Flight settings, make a screen recording, upload to YouTube (for example) and link here so we can see?

If i understand you correctly, tapping to buttons at the exact same time doesn’t work? But if there’s a slight delay between the tapping, it works?

1 Like

Okay, I will do that.

1 Like
1 Like

Well I’m the video they worked… you just have to put the Nose down first in order to get the best turning ability with the rudder.

I want to point out that I constantly press my finger on the screen !


Everything looks fine. You were able to turn and to reverse thrust at the same time.
The only thing I noticed was that the aircraft was barely turning, but this is Kemal because not all of your gears have touched.

I don’t think the problem really comes from me. You can see that I use the rudder to align myself with the track, and when the wheels touch the track, I start the thrust reversers, and that’s when the two buttons stop responding. There is no sound in this video but you can hear the engines increasing in power and then coming down suddenly. Same for rudder, you can see that as soon as I activate both at the same time, the rudder stops responding and the plane swings to the left.

1 Like

Ahh, I see. Without sound it’s rather hard to figure out the problem then!

1 Like

@Marc.Stinger I think I’ve figured out your problem.

So are you aware that the Reversers automatically stop before 60knots? This is normal. Could this be the problem you’re experiencing?

While you’re holding the reversers down, it sometimes stays at the “- “(negative) thrust.

Huh, I didn’t quite understand that, sorry.

That is, I don’t have to hold the reverse thrust before touchdown?

No, so basically when you’re holding Down the reversers, it goes until -100% right?

Then, after a short period of time the reversers stop and the sound of the reversing is gone. This is normal, because the Reversers automatically stop at the 60kt mark.