Procedures bugs

Hi 👋🏼
I faced bugs on procedures of some airports during my flight. When my aircraft was on AP, I looked on the map and saw that some airports don’t have “Departure Procedure”, I mean that I can’t see lines/ways of departure, I can only see the name of the way. Busy airport that has Class Bravo doesn’t have any procedures at all. May I receive an answer from the development team to fix that bug and avoid this problem in the future? I hope so.
Pics are down below:

It happened to me once. I restarted the app and everything was good 👍

2 Likes

yep, restarting the app or uninstalling and reinstalling work fine! it’s happened to me before, too.

1 Like

“Reinstall” - it means that all my replays of flights will be deleted, yes?

1 Like

A restart should be enough. No need to reinstall the app.

1 Like

I believe so, but usually just restarting the app is good enough!

1 Like

Can you clarify your question please?

If you are questioning why departure is not show, simply not every airport in Infinite Flight has departure procedures. O’hare for example does not because they are vectored manually.

If you are seeing an issue where you see them listed but no paths this can be solved by closing Infinite Flight, rebooting your device, and restarting Infinite Flight.

1 Like

I believe he’s saying he cannot see the lines of the SIDs/STARs. But the last two one is because the airport doesn’t have any procedure available, like Chicago O’hare. But it’s not a bug.

1 Like

image

That’s mine (normal) compared to his procedures.

1 Like

Well, sometimes I did that. Close Infinite Flight, switch off and then on my device and start the app again - but it didn’t helped me anyway.

I did just now what you recommended me:

  1. Start Infinite Flight to ensure that problem is still
  2. Close the app
  3. Switch OFF my device
  4. After a few seconds switch ON my device
  5. Start the app (IF) again
    As a result - the problem is still

Can you explain how you are recreating it? Go to ____ click on departures?

What device are you on?
Is there a difference when you zoom in/out?

I think he just copied his picture. He didn’t remake it @Chris_S:)

I cant read the airport name. Can someone give that?

The airport code is UUYY

Hmmm, I’ve tried it on UWOO and I have the same problem even after restarting

1 Like

I’ve found the root of the problem
If you look at the SIDs of UWOO on Jeppesen it seems like most SIDs consist from a turn to the waypoint. Currently IF does not implement curves in SIDs and STARs and inputs them just as waypoints, and IF also does not add the airport into your FPL when you add the SID/Approach. That means when you input the SID, you input the right and only waypoint in it, but without the arcs and stuff which are currently not implimented. If you were to start the flight in one of these airports and have the airport waypoint before the SID, everything would be alright (except for the maybe unrealistic flightpath)

I choose the airport, push the button “Procedures” and then push the button “Departure”.

Device is iPhone


It happens even when I’m in the main menu

The problem is that the SID is just a turn from runway course to a waypoint, have a look
Example SIDs


As you can see, the SID consists of flying runway heading and then turning towards a waypoint. The thing is that in Infinite flight, the curves in SIDs are not represented as of yet and every SID is just a set of waypoints. So, the correct FPL for that part of flight would be, in case of LUGES 1, UUYY LUGES, but here’s the thing: Infinite flight doesn’t add the airport into the SID/Approach, so the only thing you’re adding with LUGES 1 SID is just LUGES waypoint, which is what you’re seeing there.
So, in essence, it isn’t really a bug, but rather the way all 1 waypoint procedures look in the game. If you would be flying there, just add the airport waypoint before the SID and everything would be alright.