Problems with update

Problems with update on iPad with iOS 10.3.3?
Anyone else? Please help😩😩😩

Well let’s start off by asking: What are your problems?

Please, take a look at this topic to see how to format a Support topic. :)

4 Likes

What iPad model do you have?

1 Like

Yes experiencing the same issue

I have the latest 10.3.3 software installed on my iPad but when I go to download the infinite flight update from the App Store, it says that I need to have version 10.3.3 or newer to install it. But I already have it installed.

Cant find it its 5 years old, it sais it requires 10.3.3 for the new
upgrade and that I can only have the onder version? My i pad had 10.3.3

Gr Serge

Ipad is 5 years old, it sais it requires 10.3.3 for the new upgrade and
that I can only have the older version? My i pad has 10.3.3

Gr Serge

See here: