Problems with the app

I have been facing quite a few problems with IF in the past couple of days. I recently came back to it after being away for a period of around three months. When I reinstalled the app, I saw that the icon on the top right corner of the screen during a flight was red most of the time. It showed me that I was not connected to the Global Server. And that kept happening, although it kept fixing itself within a couple seconds. Just for the record, my internet connection is very stable.

Then, two days ago, i encountered another problem. I was approaching LTFM and I kept requesting approach to the controller. He responded to everyone but me. Same thing happened with the Tower Controller. When I asked the approach controller about it he said that he couldn’t even see me moving on the screen, and that he couldn’t send me any messages, even though I was online and I was able to hear him and others on the frequency.

Today, as I tried to open the app, it wouldn’t open. Quite literally, the app is frozen on the loading screen, while being responsive on the other hand. I can’t even get in the app anymore. I waited for about ten minutes. Then I restarted the app, but to no avail.

And all of this simply adds to another problem, that is the god enormous loading times when I try to start a flight.

Someone please fix these problems.

Device: Realme 8 5G
OS: Android 13

1 Like


Did you restart your device?

Or try going under another Wi-Fi network. Maybe the specific network is the issue.

Tried all of it. Nothing worked

The first two problems could be with the server updates, definitely worth reporting here:

For the last issue can you try a device restart. If that does not work a maybe a app reinstall, remember that removes all replay files so make sure to back up any you want to keep.

Sure. I will do that. I tried reinstalling the app. It fixed the last problem. But not the server problem

The issue with not being able to communicate with ATC has been introduced with the Beta testing that is currently ongoing. Lots of controllers have reported it and the IF team are well aware so this should be fixed shortly.

The same thing Happens to me also!

Is the global server problem also one of them?

You know the same thing that you have experienced at LTFM happened to me one time at the Canada Fly-Out event.

1 Like

Yeah I know. Turns out it’s a bug. I confirmed with the controller and he said that same thing.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.