Problem with Multiplayer

This topic is made on behalf of @PocketRishi

Hello Community

My friend, PocketRishi, is having some troubles with playing on multi-player. He has an active subscription and yet he cannot fly on live.

Any help would be appreciated. I will communicate what you guys have said over to him.

Here are some screenshots:

He is running on IOS 11 and has the latest version of the game. He has a IPhone 7 Plus. Also, if it helps, his username is PocketRishi.

Thanks in advanced!
Happy Flying,
-Igamer

Message on behalf of @PocketRishi

Hi all,

Thank you so much Igamerfellow for posting on my behalf. I am not sure why I am not able to create a new topic despite having made one earlier.

Anyways I was wondering how long I’d have to wait for the subscription to be active, as the money has gone out of my bank account already. It’s been 45 mins since the transaction, and I’ve never had this issue when I was paying $15 a month for Global (Australia) for the past few months. Is it just taking long because it’s for 6 months instead of one month?

Thank you,
PocketRishi

There’s a few recommendations that usually resolve this.

  • Open up iTunes from the device using Infinite Flight and sign out of the iTunes account if already logged in and log back into it. If not logged in simply login and then follow the step below.

  • Close the app (Infinite Flight) and restart the device. Relaunch IF and sign back in with the correct credentials.

Try those and report back.

Ok, thank you. I will pass this onto him and will pass on to you if this has worked.

1 Like

It didn’t work. He tried it twice.

He needs to contact the AppStore then since purchases are managed by iTunes. There might be an issue with the form of payment or something of that sort. Be best to contact Apple, here is the link:

Ok. I’ll tell him that now.

Https://support.apple.com

Thanks for your help Levet. I and Rishi appreciate it.

1 Like

Send me a PM once he gets this resolved. Take care.