Problem with autopilot

Hey guys I’m new to this game earlier just before I came in for my approach for landing I switched off my autopilot and for some reason my plane shot upwards and was stalling any tips on how to stop this?

Welcome to the forums!! It’s most likely because your device. In the future before disabling autopilot – calibrate!! Once calibrated, tilt your device down a little bit and then disable autopilot. It should be okay then

Okay thank you very much I will try in my next flight 😀

1 Like

No problem! If you still face the issue private message me ☺☺

I can also attest to the benefits of re-calibration before disengaging A/P.
A simple re-calibration while holding-short before take-off, and when turning onto final, should suffice.

I believe even the current trim setting will auto-factor in with the “new” neutral position of the yolk, once A/P is disengaged…though, I could be mistaken.