Problem logging in (authenticate) for live

On my S5 I updated and was logged out, so I tried logging back in but whenever I click the Google+ authentication button, either a blank white screen comes up and doesn’t load, or the google login screen partially loads but I can’t even type in my email/password. I have uninstalled and reinstalled the app multiple times, I have a very good wifi connection, I restarted my phone multiple times, still absolutely 0% success- I seem to be doing everything right


Any photos?

Yes, here i’m unable to type in the email box and the page never fully loads:


Weird. Usually it auto-authenticates.

To fix, restart device. If doesn’t work, delete and re-install the game, if that doesn’t work, make a soft reset. If that doesn’t work either, make a hard reset (does not delete IF) if nither works, smash your phone with a hammer. And if that doesn’t work, throw your phone into fire.

None worked and I’m not fully resetting my phone

Is your memory full? That may be why it isn’t loading.

P’S don’t tag the devs, I learned from experience lol.

I have plenty of space on my device, and plenty of RAM

Are you trying to renew?

No, I got logged out when I updated, and I’m trying to log back in

Restore purchases?

doesn’t that delete everything? And then I lose my 50$?

Don’t think so, it should just give you back what you had, someone else may want to confirm though…

I can’t restore purchases because I can’t login on the app

It will keep your apps and iAPs. At least for me.

Hi there. Seems like you’re stuck in a little bit of a pickle here… I’d give a shot turning wifi off and on again, I’ve read through comments and see that you’ve basically tried everything, so if nothing else works maybe try not going on the app for a few hours, and the problem may have resolved itself. If it persists maybe try contacting Samsung support or similar and see if they’ve got any tips.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.